Federation following or not?

I wrote about some problems I was having at Federation not working for me but I think I’ve identified a more fundamental problem and rather than clutter up that topic I figured I’d put the new information in a new topic.

I have several blogs on write.as with a custom domain of richholmes.xyz. They are Federation enabled with addresses of @blog@doctroid.richholmes.xyz, @blog@walkinginspace.richholmes.xyz, @blog@analogoutput.richholmes.xyz, and @blog@mathematrec.richholmes.xyz (the addresses shown on the Customize pages for those blogs).

From my Mastodon accounts at vmst.io and writing.exchange I looked for and found the first of these and sent follow requests which appeared to have been processed successfully. On vmst.io I likewise followed the other three blogs. They all appear in my following lists on those Mastodon instances. However I get no new content from them in my feeds.

But at write.as the stats pages for those blogs say I have zero followers.

So the Mastodon instances think I am following those blogs, while write.as thinks I am not.

For instance, from my Following list on vmst.io:

but from https://write.as/me/c/rsholmes/stats :

Hey, I was able to follow your @blog@doctroid.richholmes.xyz blog from Writing Exchange… Could you try unfollowing it, then following again? As far as I know, there aren’t any issues with federation on Write.as at the moment…

There are many quirks about Mastodon and the fediverse that could cause something like this, though. For example, if you tried following a blog at your old @your-blog@write.as handle, things can get wonky in Mastodon. The fediverse doesn’t actually support changing usernames, so you need to be sure you’re following your current, permanent handle. If you notice that it says “request pending,” then something is off, as we don’t actually have follow requests on Write.as – Mastodon just shows that when something goes wrong.

Looking at @blog@doctroid.richholmes.xyz on writing.exchange I saw it said the blog had 1 follower (and that I was following it). I hit Unfollow and the blog’s follower count was shown as dropping to 0. I hit Follow and it came back up to 1. I’ve done this several times.

Meanwhile on my blog it says I have 1 follower, namely you, and that does not change when I follow or unfollow from writing.exchange.

Hm, some sort of progress, but not enough…

I unfollowed and refollowed at writing.exchange. Posted a test post on the blog and it showed up in my feed!

I unfollowed and refollowed at vmst.io. Posted a test post and it did not show up in my feed. (It did show up at writing.exchange.)

And yet at write.as it still shows only one follower: @matt.

Similarly I created a blog at paper.wf and followed from both writing.exchange and vmst.io, new content appears at the former but not the latter.

But according to paper.wf I have only one follower. (Older WriteFreely, does not show who the followers are.)

So, seems I’m seeing expected behavior at writing.exchange but not at vmst.io or at write.as or paper.wf. Any ideas?

@matt I am still seeing these problems and would appreciate your assistance. Why does write.as show only one follower (you) on @blog@doctroid.richholmes.xyz when in fact I’m successfully following that blog from writing.exchange?

Is @blog@doctroid.richholmes.xyz in fact being followed also from @doctroid@vmst.io?

The latter thinks it is following the blog but it is not getting new content. Is this due to problems on the vmst.io end or at write.as? If the former, what information can I give the vmst.io admin to get it corrected?

Just starting with writing.exchange, does that Write.as post show up in your Home feed? Or Local Timeline? If it’s only the Local Timeline, not Home, you’re not actually following the blog.

Either way, before following or unfollowing again, can you open your blog’s profile page there, hit refresh, and then send a screenshot of what you see? Again Mastodon has many weird UI quirks around following so I need to be sure the request has fully gone through before looking at anything on our end.

Home feed.

Note it says two followers. Meanwhile on write.as it shows one follower.

And vmst.io claims to be the one and only follower, but gets no new content:

Thanks! I finally figured out what was happening, and fixed the issue. If you try unfollowing and following once again, it should work. Please let me know if not.

The issue was a bug, introduced in late April with the new verification feature, that meant that new fediverse followers previously unknown to Write.as would fail to save on our end. That’s why my Mastodon account could follow your blog (I already follow other Write.as blogs), but yours wouldn’t.

Sorry for the trouble this caused, and thanks again for reporting and debugging. Along with the fix, I deployed more robust error reporting recently that will help catch these issues much sooner.


Well, it’s progress.

I unfollowed and followed from both writing.exchange and vmst.io. Both now appear along with you in the Subscribers list!

Test posts to the blog do appear in my writing.exchange Home feed. But they still do NOT appear at vmst.io.

Of course that could conceivably be on the vmst.io end. Is there something the admin there could check? Or is it something you could diagnose?

Still hoping for some help here @matt.

I am getting really, really frustrated by the fact federation isn’t working for me and I can’t even get a response let alone a solution from @matt or anyone else in the know here.

Latest news is two new test posts have been made at @blog@doctroid.richholmes.xyz which is hosted at write.as/rsholmes. I am following this address from Mastodon instances mastodon.social, vmst.io, and writing.exchange. All three Mastodon instances are indeed listed as subscribers to the blog on write.as. But:

  • Both test posts appeared immediately in my home feed at writing.exchange, but not at all on the other two.
  • At writing.exchange it says the blog has 15 posts and 2 followers. At the other two Mastodon instances it says 13 posts and 4 followers. All three are wrong. In fact there are 15 posts and 4 followers.

Sorry for the frustration but unfortunately much of this has to do with servers and software I don’t make or control – such are the joys of decentralization. To your points:

Okay, glad that bug on our end seems to be worked out.

Without having any control over those other servers, unfortunately it’s hard to tell exactly what might be going on. If you can reach out to the admins of those servers to let them know what’s happening, they can probably help much better than I can. They might refresh your blog’s information on their Mastodon server to pull in fresh info and ensure your posts load there.

This is an issue with the Mastodon software that will probably never be fully fixed. Mastodon doesn’t pull in old posts, only shows followers that the local server knows about, etc. See this issue and this comment for example.

But I asked over a week ago

to which you never responded. I also posted two questions about Mathjax one of which one user responded to with the implication that proofreading Mathjax on WriteFreely is impossible, but no response on the other. I also see at least four questions from other users posted here three to five days ago to which no responses have been given. Users need better support than this.

I am not knowledgeable about this subject. I do not really know what questions to ask or what information to pass on to the Mastodon admins. In fact I have tried to ask one of the admins and haven’t gotten anything from them either, but maybe that’s just because I don’t know what to ask.

My bad for missing that, I’m responding to many people and can sometimes miss details.

You’re absolutely right that users need better support, and I’m trying to improve that. But I’m the only person doing everything here, from coding to support. So, as I mention on our contact page, I just need a little patience from everyone because of that.

As for the issue here, if you ask the admins to refresh your blog’s information as mentioned above, hopefully that will help. Hopefully they get back to you.

Otherwise, I’ll try to dig into your Mathjax question as soon as I can.

1 Like

Top marks, love the vision.