Federation Troubleshooting

troubleshooting
writefreely
writeas

#1

This thread is for some common issues / weirdness you may encounter with your blog in the fediverse. Please feel free to ask any other questions here.

Not finding your blog

First, make sure you’re searching for your blog in one of these formats:

In particular, the URL must include the https:// portion.

If your search is formatted correctly and you’re on Write.as, make sure you’ve gone to your blog settings (from this page) and Enabled Federation.

If your search is formatted correctly and you’re on another WriteFreely instance, make sure that your instance admin has enabled federation. Right now, the best way to determine that is to go to https://{your-wf-instance}/api/nodeinfo – if some funky data stuff comes back, then federation is enabled. Otherwise federation isn’t enabled, and you won’t be able to find your blog from the fediverse. Get in touch with your admin to have them enable federation.

No posts showing up when you search for your profile

When you search for your blog, Mastodon only pulls in some metadata about it, like its title, description, post count, etc. It doesn’t pull in existing posts (I’ve opened an issue to have this fixed in the future).

You’ll only start seeing your posts once you’ve started following the account. So to be sure you receive all your blog posts, follow your blog before making your first post.

If you’ve already posted and would like to import your old posts, you can search for each individually in the Mastodon search bar. Doing so will import the post, and it’ll show up in your blog’s profile view on your instance, and well as the federated timeline.


Any other issues you’ve run into?


#2

Actualy there is no preview of post image when sharing with mastodon… Only the Write.as logo… This can be a cool feature for visual blogs

09


#3

Normally the platform should extract images and display them there (and on other social networks). On this post, it looks like in the Snap.as photo fell back to a .image extension, which we previously weren’t checking for. This is fixed now! (commit: 8a07c0f)


#4

Now I have no federation at all… After some hours, the Mastodon instance still don’t see my new post


#5

Just to be sure, are you following your blog from that Mastodon instance?


#6

Yes ! No update for today post… Maybe the problem is with this particular instance…


#7

Hmm, mind sharing what instance that’s on? I’ll take a look at the server logs to see if something went wrong.


#8

#9

Maybe some of these informations can help…

1-- I follow my blog on Mastodon (mamot.fr) at this address/identity and is not updated with new posts: @blognotes@aris.papatheodorou.net

2-- If I search on Mastodon for a particular post from my blog (ex: https://aris.papatheodorou.net/particules-elementaires) he found the page and point to the correct URL… but the blog address/identity is set to @aris@write.as not to @blognotes@aris.papatheodorou.net

3-- A friend who tried to follow the blog from Hubzilla (hub.disroot.org) with @blognotes@aris.papatheodorou.net said me he had this error message:

{"code":404,"error_msg":"Collection doesn't exist."}

The request to the API generated by Hubzilla was this one:

https://aris.papatheodorou.net/api/collections/blognotes?f=&zid=seeker0%40hub.disroot.org

21


#10

Now I know…

Federation is broken for custom domain (ex: https://aris.papatheodorou.net)

Federation work fine wit Write.as default URL (ex: https://write.as/aris)

26 55


#13

Sorry for the delayed response here. When I search for your domain in Mastodon, the username that shows up is @aris@aris.papatheodorou.net. If you changed the username after following the account, you won’t see any new posts come in, as Write.as is sending out posts under your new fediverse username, which Mastodon and other fediverse software won’t connect to your old one (@blognotes@aris.papatheodorou.net)

Changing usernames is largely unsupported in the fediverse, unfortunately. It’s basically like creating an entirely new account, where everyone needs to re-follow your new username to get your posts. This is an ActivityPub thing, not specifically a Write.as thing (though I will document this somewhere, so it’s clear).

Can you try following your account again from Mastodon, ensuring your new username shows up, and seeing if that fixes things?


#14

Hi,

In fact I reverted to default Write.as ActivityPub ID/Adresse (@aris@aris.papatheodorou.net) for testing purpose, because my custom one (@blognotes@aris.papatheodorou.net) was not working at all.

In clear : I’m not following anymore my blog with @blognotes@aris.papatheodorou.net but with @aris@aris.papatheodorou.net

Doing this, my last post was correctly found by Mastodon, with the preview image… I am waiting now for next post to see if it federate…

I also follow my blog from @aris@write.as. This grabbed the two preview posts… but not the new one.

I will try in next days from an other Mastdon instance.

Really this is a ghost in the machine :frowning:


#15

I’m not getting any federation from my blog to Mastodon… I have to manually search for all new posts in order to see them in Mastodon.

I followed my blog right from the get go. I also use a custom domain.

I also don’t see new followers in my Mastodon for my blog - the only one showing is myself, the next new follower is not showing.

Some of this may be Mastodon rather than Write Freely…?


#16

Do you mind sharing your handle here or privately? I can take a quick look to see if something looks off.

Mastodon doesn’t pull in the full information about followers – this is something we’d have to display in WF.


#17

@matt - did you shine any further light on federation issues I am having…?


#18

Is the point of Federation privacy or community? Being not technical, I’m not getting why I should or shouldn’t move forward with it. Thank you.


#19

Thanks for sending along the info. I didn’t find any issues with your instance, and indeed I followed the blog from my instance and received your most recent post automatically. Have you tried unfollowing / re-following your blog more recently?


#20

The point of it is mostly community. It’ll make the most sense for anyone who uses services like Mastodon, but you can also see how it works in this video.


#21

Thanks for getting back and testing from your end.

I have this evening unfollowed and I will re-follow later. Just putting a post together that I will then see if it federates automatically.


#22

Thanks Matt. I finally figured it out. Is the community mostly within Write.as, or is it across other social platforms. That was my main confusion. Thank you, again.