Cannot seem to publish post

I wrote a new post, hit publish and got the “page is missing” message. On the rare time that this happens, I’m usually able to go to the blog’s homepage and the new post will show up there. But not today. I tried publishing a post twice and got the same error message.

Anyone else running into the same issue?

Okay my post finally showed up. Maybe there is an extra delay happening today?

Yeah, it looks like some things are moving slower than normal – but I’ve just sent out a fix for this (more below).

Whenever this issue happens, it’s because your post data, written to our primary database, hasn’t yet been copied to our replica databases. So immediately after publishing, we try to load a valid post from the replica, but the data isn’t there yet, meaning you see that “page is missing” message.

The fix I just sent out should permanently fix this for writers in the web app. Now immediately after publishing, you’ll always retrieve the post from our primary database – so you shouldn’t see the “missing” error at all.

1 Like

thanks @matt