Yet another bunch of comments on this service

Yet another bunch of comments on this service. Note: I plan to write technical blog, i. e. blog with a lot of code fragments, etc.

  • If the post is supposed to be published in serif font, then in editing mode I see everything in serif font, too! This is strange. I should see my post in monospace when editing, even if it will be published as serif! Let me describe why. Let’s assume I’m authoring a document in “serif” mode and I added a code snippet with some ASCII art using <code> tag. Then in editing mode I see everything in serif, but in final document main content will be in serif and that <code> contents will be in monospace. So, when editing I cannot see how this ASCII art will look in resulting document. So, again: please always show monospace in editing mode
  • You have no “preview” button. This is very unfortunate
  • MathJax doesn’t work in anonymous posts. There exists a hack, which allows one to somewhat enable “preview” button: just write post, then publish it anonymously, then edit again, then again publish anonymously, etc. And finally publish it non-anonymously. Unfortunately, this doesn’t work with MathJax, i. e. you must somehow get MathJax right for the first time!
  • There is no full instruction on all features supported by markup. I was unable to find a single document, which describes all features supported by your flavour of markdown, including MathJax. I. e. I didn’t find such a document in official documentation, so I have to search through this forum. This is very bad
  • doesn’t support APNGs, they are silently converted to normal PNGs. Also, if you add support for APNGs, then, please, document support. There was incident in the past: Twitter enabled APNG support by mistake. And then they immediately disabled it back. So, please provide APNG support in both and and document it. I. e. write that this is not mistake, that APNGs are actually supported

And finally, here is instruction how to embed Godbolt to HTML: Compiler Explorer's embedded view — Matt Godbolt’s blog . I tried to do this and failed! Here is example embedding code:

<iframe width="800px" height="200px" src="!((g:!((g:!((h:codeEditor,i:(filename:'1',fontScale:14,fontUsePx:'0',j:1,lang:haskell,selection:(endColumn:1,endLineNumber:1,positionColumn:1,positionLineNumber:1,selectionStartColumn:1,selectionStartLineNumber:1,startColumn:1,startLineNumber:1),source:''),l:'5',n:'0',o:'Haskell+source+%231',t:'0')),k:47.65292159413079,l:'4',n:'0',o:'',s:0,t:'0'),(g:!((h:compiler,i:(compiler:ghc961,deviceViewOpen:'1',filters:(b:'0',binary:'1',binaryObject:'1',commentOnly:'0',debugCalls:'1',demangle:'0',directives:'0',execute:'1',intel:'0',libraryCode:'0',trim:'1'),flagsViewOpen:'1',fontScale:14,fontUsePx:'0',j:1,lang:haskell,libs:!(),options:'',overrides:!(),selection:(endColumn:1,endLineNumber:1,positionColumn:1,positionLineNumber:1,selectionStartColumn:1,selectionStartLineNumber:1,startColumn:1,startLineNumber:1),source:1),l:'5',n:'0',o:'+x86-64+ghc+9.6.1+(Editor+%231)',t:'0')),k:8.359417893287132,l:'4',n:'0',o:'',s:0,t:'0'),(g:!((h:output,i:(compilerName:'x86-64+ghc+9.6.1',editorid:1,fontScale:14,fontUsePx:'0',j:1,wrap:'1'),l:'5',n:'0',o:'Output+of+x86-64+ghc+9.6.1+(Compiler+%231)',t:'0')),k:43.98766051258208,l:'4',n:'0',o:'',s:0,t:'0')),l:'2',n:'0',o:'',t:'0')),version:4"></iframe>

When I inserted this to my document, Godbolt embedding became too small. So I have to move “width” and “height” to CSS so:

<iframe style="width: 800px; height: 200px" src="!((g:!((g:!((h:codeEditor,i:(filename:'1',fontScale:14,fontUsePx:'0',j:1,lang:haskell,selection:(endColumn:1,endLineNumber:1,positionColumn:1,positionLineNumber:1,selectionStartColumn:1,selectionStartLineNumber:1,startColumn:1,startLineNumber:1),source:''),l:'5',n:'0',o:'Haskell+source+%231',t:'0')),k:47.65292159413079,l:'4',n:'0',o:'',s:0,t:'0'),(g:!((h:compiler,i:(compiler:ghc961,deviceViewOpen:'1',filters:(b:'0',binary:'1',binaryObject:'1',commentOnly:'0',debugCalls:'1',demangle:'0',directives:'0',execute:'1',intel:'0',libraryCode:'0',trim:'1'),flagsViewOpen:'1',fontScale:14,fontUsePx:'0',j:1,lang:haskell,libs:!(),options:'',overrides:!(),selection:(endColumn:1,endLineNumber:1,positionColumn:1,positionLineNumber:1,selectionStartColumn:1,selectionStartLineNumber:1,startColumn:1,startLineNumber:1),source:1),l:'5',n:'0',o:'+x86-64+ghc+9.6.1+(Editor+%231)',t:'0')),k:8.359417893287132,l:'4',n:'0',o:'',s:0,t:'0'),(g:!((h:output,i:(compilerName:'x86-64+ghc+9.6.1',editorid:1,fontScale:14,fontUsePx:'0',j:1,wrap:'1'),l:'5',n:'0',o:'Output+of+x86-64+ghc+9.6.1+(Compiler+%231)',t:'0')),k:43.98766051258208,l:'4',n:'0',o:'',s:0,t:'0')),l:'2',n:'0',o:'',t:'0')),version:4"></iframe>

And now Godbolt looks a lot better! How I supposed to know this? If this is a bug, then fix it. If not, then document

So, please, fix this problems

1 Like

I am paying consumer

If is not designed for technical blogs, but is instead designed for fiction writing, then, please, say so explicitly

I second the need for monospace font in the editor and a full post preview that also renders MathJax and all supported formatting.