Www. and SSL handshake failed Error code 525 issue with domain on write as

Not sure if support will respond again at this point, so I thought I would make this question open to see if I can try something I have not thought of yet. Basically, I have two domains set up precisely in the same way via Cloudflare on write as. www.writecropley.blog works fine on this domain, and www.twisted.place does not, at all, I just can’t work out why, I feel like I have tried everything at this point, since moving the domain DNS to Cloudflare, though, I now have the error “SSL handshake failed Error code 525” but then upon trying everything suggested on my end it still does not work. Note its only the www.twisted.place domain here that’s not working, everything else is working fine.

Hey Jamie, we can continue working through this here if you want. See the “CloudFlare” section of this topic – you’ll want to change your settings to “DNS only”:

1 Like

I done that, lets hope it works… so far nothing has changed. See my support thread as well, I added everything else I have tried.

Well, the good news is I am back to the original error (after following all the instructions in that thread) lol: ERR_SSL_PROTOCOL_ERROR I also regenerated the certificate on Cloudflare. It is becoming beyond frustrating now because I can’t see a solution.

I think at the moment, I keep coming back to the place where the blog is hosted on write as server. It seems like its picking up everything fine for the certificate until it comes to www. because the other site I have works fine, but this one don’t, I wish I never disabled my domain on my site temporarily now lol.

Okay. Sorry, I think misunderstood what you were going for in your other emails. Since you want your official domain to be “twisted.place,” it looks like you’re all set. The site is live and working well.

When you have a top-level domain (i.e. twisted.place) set as your Write.as blog, that is the domain we generate a certificate for. Since, again, “www.twisted.place” is an entirely separate domain, we don’t generate a certificate for it. So that’s why you’re getting that error.

If you want to set up www.twisted.place to redirect to twisted.place, you’ll need to do that through another service. I’m not sure if CloudFlare will support it, but many hosts and registrars will.

It’s strange because how has it done it for www.writecropley.blog and not for www.twisted.place when I configured them the same? I presumed to write. as did generate the certificates for both www. and the naked/top-level domain? Because from what you have no said, I should then be able to switch www. back to proxy and cloudflare generates the SSL certificate, but then when that happens that’s when the handshake error occurs because no such certificate exists on write as server. I think even in this respect if I managed to do it through another service, write.as is not compatible respective of the initial handshake error I had?

At the moment I am trying something, doing away with cloudflare, resetting everything, deleting blog from write as then setting up again from scratch (hoping it will regen SSL on server side), setting DNS to default, gonna wait 48 hours see if that solves all my issues, if not I will just deal without the www.

@support Are you certain there is nothing on your end preventing the www. working on twisted.place domain? It’s just I set up another blog, and the www. works find with me.writeas.com should I contact the registrar at this point? Note none of them are no longer on cloudflare. I even deleted the twisted.place blog and started it from scratch on write.as




Note the www. domain is additional as stated, to my main naked domain.

www.twisted.place (blog has been completely deleted and set up from scratch)

www → me.writeas.com = ERR_SSL_PROTOCOL_ERROR
www → twisted.place = DNS_PROBE_FINISHED_NXDOMAIN
www → twisted.place. = DNS_PROBE_FINISHED_NXDOMAIN



www.alien.observer (a brand new blog I set up from the start to test)

www → me.writeas.com. = Site loads fine


www → me.writeas.com. = Site loads fine

At this point I have no idea what I can change or do to get it working. You mentioned additional services which can achieve this, but I am not sure what services are you referring to? Are you 100% certain its nothing on the writeas server end?

I have looked through historical records as well and such on this domain, where I have had twisted.place set to www. in the past, it has worked fine.

Again if anyone else knows any solutions it would be very helpful.

I am clueless what to do next so I opened up the question here to try and find new solutions: networking - If a www. subdomain via a CNAME record pointing to a host address comes up with errors is it a server fault or a DNS settings issue? - Super User

Hey, this is information overload for me right now :slight_smile:

Things work exactly how I described them in my last post. We simply do not support two different domains pointing to a single blog on Write.as (i.e. www.twisted.place and twisted.place). You’ll want to pick either one or the other. It is entirely on our end, it is how things are designed, it’s how they’ll stay for the foreseeable future. But by all measures, your sites are already working perfectly on their custom domains.

As for using another service to redirect from www to non-www domains, this Stack Overflow answer should get you started in the right direction. But it’s out of scope for Write.as.

Hope you have a good weekend, and I’ll talk to you on Tuesday after the holiday, if you still need anything.

Sorry about that, more just been updating / trying to document everything as I go, tbh could do a better job of that and put it one post or something so apologies.

“Things work exactly how I described them in my last post. We simply do not support two different domains pointing to a single blog on Write.as (i.e. www.twisted.place and twisted.place)” Yeah, that is the main / exact thing that’s confusing me, why one name registrar is actually allowing it go through on both www. and the naked domain (namecheap) and one is not (gandi) and perhaps that’s best left for the stack exchange question I asked to answer / gandi support, because the settings are slightly different on gandi. I even thought about transferring the domain to namecheap, but I can’t afford that right now which is annoying (is around £25 GBP) as I reckon that would solve a lot of my issues. But that’s the annoying thing with domains, some registrars I find can offer very slight differences in how they operate and what you can configure, and sometimes its the hard part figuring out how ,what, why etc…

Thanks for the help anyway. I will stop updating this for now unless I get any useful information from gandi that could help others I will post it here, as again the fact you said writeas don’t support two types of domains (even though when I tried to do www.twisted.place on its own actually it still did not work) I will just take that as what it is and move on in my investigation from there.

So overall, yourself / write.as does not support naked domain and www together, however namecheap strangely somehow does, and gandi does not at all also.

My overall thought / question is why any domain I put through on namecheap for write as works both with www. and the naked domain, how strange?

Found this: Domain registrar allows @ CNAME for root domain, is this reliable? - Server Fault meaning gandi probably don’t support CNAME in the same way as namecheap does? However my attempts on cloudflare perhaps its worth me trying again on there with it.

So I fixed this issue now. I just purchased a very cheap domain on name cheap, and the www. and https work together again , I got rid of the twisted place one as I was looking at a rebrand of it anyway. I know you said they are both not meant to work but for some reason on namecheap they do, from my research it seems some domain registrars allows this and some don’t ( Domain registrar allows @ CNAME for root domain, is this reliable? - Server Fault ) see here. Anyway feel free to lock this topic.