Writefreely client stopped working

IOS… “it’s dead jim!”

… what happen?

Halp.

@support - I can’t post anything from the client.

Hi @18percentgrey, sorry to hear that things aren’t working right! Let’s get collect some info to solve this problem together. Please answer the following:

  1. What version of the WriteFreely app are you using? Tap the gear button in the lower-left of the post list, and near the top of the Settings sheet, you should see “WriteFreely v1.0.X (build NNN)” — what does it say?
  2. What device are you publishing from, iPhone or iPad? What version of iOS are you using? Go to your phone’s Settings app > General > About to get the Software Version (e.g., 14.4.1)
  3. Are you publishing to Write.as or a WriteFreely instance?
  4. Have you changed your password on Write.as/WriteFreely recently?
  5. Are you getting any error message when you try to publish?
  6. Could you give me a detailed step-by-step guide so that I can try to do exactly the same thing on my iOS device?

writefreely 1.04 build 600
iPhone
iOS 14.4.1 updated last night, after this started.
server: https://write.as, also tried it with write.as and no https://

I haven’t changed my pwd in months. :-).

When i try to publish, i see a tiny blip when i hit the tree blue dots but then nothing good happens and the menu doesn’t pop up.

no error message to speak of. Just … it doesn’t do anything. Even an anonymous post doesn’t work and none of my other blogs either.

Procedure:
Sure- log in, write a post with a title and some message body, try to publish it…

( for me it does the above quagmirical issue rather than working reliably as it has. Very weird. Want another video?

It seems like some sort of error in iOS but all my other apps work …
Additionally , i tried installing writefreely again after an un-install a reboot and reinstall action. Same same, no dice.

Hmm, interesting. Try logging out of the app, then back in, and try publishing a post again — and if you could record a short video, that’d be helpful!

(Don’t record the login process, please — we don’t want to risk you publishing your password in some way. Just record what happens when you create a new post and publish it.)

1 Like

Angelo somehow it all works again… i cannot guess but i would guess there was some kind of stuck PID or something on the server and eventually it got fixed by the powers of linux. :D.

If yall did something, thank you. That was driving me nuts.

@angelo it stopped again so you get that video after all.

Sad dev panda face hold on I’ll demo it

^ doing super wonky stuff that it wasn’t before … you’ll see.

@matt you should see this as well.

Thanks gents.

Hmm, there’s a lot going on there, and I agree that something unexpected is happening. I’m going to have a closer look at this video and make some notes for us to compare — really sorry that it’s not working as expected for you!

1 Like

Thank you, yeah it’s weird a*… and trust I have indeed already turned it on and off again and all of these types of things. :partying_face::rofl:. Also, thank you Angelo.

This is still waay broken. I’ll try logging out again :slight_smile:

Any traction on a possible solution ?

I spent about an hour and a half investigating this and I’m really struggling to reproduce what you see. Can you help me confirm a couple of things, @18percentgrey?

  • Which model iPhone are you using?
  • It looks like you’ve set your phone to use a larger text size (via Settings > Accessibility > Display & Text Size > Larger Text). Is that right?
  • Do you have any other accessibility features enabled?
  • Are you using any hardware accessories with your phone, like a bluetooth keyboard for example?
  • Do you log in and out of the app regularly, or do you log in and stay logged in between launches?

What’s most curious about this is that I can see in the video that you’re tapping the menu button to publish the post, and it comes up and is almost immediately dismissed. The on-screen keyboard is present too, which should be dismissed whenever you tap the menu button. I’m trying to understand how the app can get into this state, but don’t have an answer yet.

In the meanwhile, maybe try this:

  1. Log out of the app.
    • :warning: NOTE: This will delete any edits you’ve made to published posts but haven’t pushed to the server.
  2. Delete the app by long-pressing on the app icon on your home screen, and choosing “Remove App” from the context menu. You’ll have to confirm that you want to delete the app a few times.
    • :warning: NOTE: This will delete any local posts that you haven’t published to the server.
  3. Re-download the app from the App Store. Launch it, then log back in and see if it works as expected again.

Yes to larger text size
Yes to the bluetooth keyboard which i havent used for a few days.

Will try the below again
And no other accessibility features enabled,

Will come back after lunch with results :slight_smile:

Thank you so much thusly for the sleuthing, this is indeed an interesting situation.

I really appreciate your patience and your help with this, I’m very sorry for the frustrating experience!

One other thing I’m curious about: do you normally log in and out of the app regularly, or do you log in and stay logged in between launches?

I never log out. :). Only for these tests, haha -!: and a few times out if curiosity

Okay i changed text size to the smallest in dynamic type and nailed the other “” larger text “” setting off… how would the dynamic type mess it up? Doesn’t react and go support that?

It seems to work for now but I’m 38! And may want to see it a little larger. LoL. I also rebooted and did remove the app flat and logged back in after a fresh start.

Interestingly this also has reduced crashes in “cryptonium” maybe the framework is the same and not such that it fully supports the text resizing thing?

Thank you for your help And your patience as well haha! :slight_smile:

Oh and its an iphone x

The iOS app is built in SwiftUI, so it should support Dynamic Type without issue. If you bump the text size back up to where you had it, does it trigger the issue again? You should be able to use it at whatever size works best for you, so if it isn’t, that’s a serious bug — though I’m not sure if it’s with the app or with the SwiftUI framework.

1 Like

All good after not using a bluetooth keyboard.

For what thats worth.

1 Like