Write.as adds nofollow (rel=nofollow) to all links in posts by Pro accounts

Just a small mistake I noticed:

People with Pro accounts will, I think, be surprised to learn that all their links are annotated with rel=nofollow. This attribute essentially flags these links as untrusted or suggests they are part of comment spam or paid links. (Wikipedia has a page on nofollow.) I can imagine some authors would prefer write.as not annotate every link in their posts with the flag “this is comment-spam”. Perhaps they could be given the option to opt-out of these editorial additions?

Neither wordpress.com nor ghost.io add nofollow to links in posts, as far as I can tell. Examples: https://mashimo.wordpress.com/2017/07/26/logistic-regression-with-python-statsmodels/ , https://cucumber.ghost.io/blog/example-mapping-introduction/

Thanks for a great service.

Yeah that’s… not great.

Thanks for this catch @cornell! This would probably explain why @bix encountered some problems when trying to pingback a post he wrote about here. We’ll look into this for sure.

1 Like

Oh good point.

Just a clarification, AFAIK the nofollow link relevance is meant to signify web crawlers are not to follow them. That is they are not part of the site linking them.

I’m not sure if that is what they are being used for in writefreely, but it’s not a spam marker.

Except that many blogging site, for example, automatically add nofollow to all links used by people in blog comments, precisely because blog comment so often have spam in them. Whatever nofollow might or might not have been intended for, other things have been heaped upon it, culturally.

1 Like

And it does depreciate the value of the links, I don’t know why for sure, but it is being added during the HTML sanitization. Maybe not for a specific reason but because it was recommended?

Either way I think maybe Pro users should have this disabled, as their content could be trusted by default. With the ability of an admin to activate it on a per Pro user basis.

Then on self hosted instances it could be a configuration or build option.

cc @matt for thoughts

This is added in Write.as / WF to prevent instances from having their search rankings ruined by spammers.

A common thing spammers will do is utilize a domain with high search authority to link back to their low-quality domains and boost their rankings. Adding nofollow prevents that, letting Google et al. know that they shouldn’t consider the WF instance linking to their sites as an endorsement.

There would still be some potential for abuse on Write.as since we’re relatively inexpensive, but I’m open to figuring out a way to disable it for Pro users.

As for WF, we’ll have to figure out a good way to do it. Most multi-user admins will probably want the current behavior (many have seen spam problems). But I could imagine disabling it for single-user instances, for example, since the single author is trusted.


I can see it being added to read.write.as or even write.as/name posts. If it gets added to custom domains or to name.writeas.com, I’d probably switch to ghost.io over this (even though I really appreciate write.as’ support for activitypub.) If wordpress.com and ghost.io don’t feel a need to add nofollow, I can’t conceive of any justification for write.as doing it.

Also, if you want to protect the domain reputation of writeas.com (although I don’t think name.writeas.com content affects it), you could create something like writeas.io or similar which would permit Pro users to control their hrefs. (I still think this would be excessively cautious; you should follow what wordpress.com and ghost.io do.)


on a related parallel a year later i really need to tweak server side .htaccess for how my ‘ions’ account handles the packets from my webserver. which is complicated.

its running 200+ domains as apache2.x vhosts. without adding any more complexity, you can see how i have the following problem without editing apache.conf (does anyone want to do that, ever?) lol no we dont.

i have this problem:
a domain hosted as dns only and apportioned like the tutorial “learn how” in “customize’”.
i have all that plugged in. and i know its in the right places, (unless specifying the internal write-as username as the cname value messes things up and that itself is causing all myproblems) but i cant get myblog to resolve otherwise all four ways,

and so far all four ways dontwork and its really driving me nuts.

i can see the tweak id need to make on your end:

RewriteEngine On

RewriteCond %{HTTP_HOST} ^yourdomain.com [NC]

RewriteRule ^(.*)$ http://www.yourdomain.com/$1 [L,R=301]

but also i know how picky this crap is, and how it has definite problems with redundancy that are actually design cues to prevent us from ruining the internet by trying to implement what we are but making sure that it is never done just the wrong way. (good systems design, dns.)

but okay so, its making problems for me here.

i cannot access the same domain as “FQDN” , FQDN+www, FQDN+https, FQDN+(permutations therein )

they dont all work, and the options combination to get it to work i dont think is accessible to me, and i have a lot of eeyeballs on my stuff, lol so i want people to feel “secure” reading it
even though as data scientists we all know how funny that is. but wish itwasnt so and want to fix it.

ok omar slow down.
i cant get https://mydomain, http://www.mydomain, and https://www.mydomain

all playing nice with my blogs and i believe i set it up right.
ive tried a lot of tricks. help? my computing server is complicated. see above. i got nervous even describing it!

@cjeller1592 read this one first. ty. and lol.

Digging this up to mention that we’ve just removed rel=nofollow from links on Pro and Team blogs:

In WriteFreely, we’ve removed them from single-user blogs – but maybe there’s some other configuration setting we could use to disable them?