Submit.as submissions not working

okay, so i was real excited about submit as, and still am. but its only worked a handfull of times. now every submission i see an email and a line item for, but click and immediately am whisked to a blank mark down document, and i cannot approve it to see if it “caught gear” but the resource appears to be blank…

been about 10 days now and i cannot find a solution. help?

Sorry for the issue! We’re looking into it now and will update you here when it’s fixed.

shoot! thanks Matt! :slight_smile: I’m figuring something just needed to be kicked a little bit gently. If this has anything to do with an javascript error and port matching-https://write.as/i4679/interesting-error

Hmm, I’m not sure that’s it… Could you send @support a screenshot of the page that fails to load (including the page URL)? That’ll help us debug.

1 Like

sorry- sure
Hi @support

I am a write.as pro user (16 blogs) - but this is a submit.as issue .
it worked a few times, but now all my external author submissions- including all my own tests, are all blank- with no “accept” button.

screens are here:

oh, ha. i got side tracked using write.as. does this work?

https://write.as/me/c/the-mind-unchained/submissions

is broken, and all the rest of them, but i suspect something happened and the problem lies here, dont know why.

heres my queue on the-mind-unchained:

https://write.as/s/efld4kombm1zn [stuck]
https://write.as/s/x0id7l03jhnd2 [stuck]
https://write.as/s/w6c39yb62rgr9 [approved normally, the button appeared]
https://write.as/s/zscpso7jpbbrq [stuck]
https://write.as/s/yhpwp2u7cvie6 [rejected]
https://write.as/s/12oz913pbfq0q [rejected]

somehow, it broke after this, and its probably something to do with how write.as accepted info from her connection. i think it corrupted some json data or ? some something in a file that references my entire account. [ions] because submit.as works no-where, and i have tried 11 or so browsers.

ok screen?
well literally i’ll upload 2- the rest would be grey screens of those above urls, and thats not efficient so there is that list instead.

2 screens here:

www.linkmeow.com/screenshots/2020/oct/submitas

sorry this took me so long to get back to, I have been INSANELY busy.

still broken. :: sad panda :: trying to be productivity panda. Any traction?

https://write.as/p/yucbom70nsgaqbe2

cc @matt

Hi @18percentgrey,

I can see your prompt. It’s working at this link here:

The above links you are sharing are links that only work when logged into your account — nobody else will be able to see them. Prompts are only visible to the public from your blog’s submit.as link. Your other prompts should be showing here…

And only accepted submissions will be shown to the public on your blog here:

Hope that helps!

1 Like

it does, mostly, actually quite a lot thank you.

here is some almost unstuck-iness tho:

like, where is my accept or reject button heehee um? :stuck_out_tongue: something is off, no?

Glad to hear!

So if you click on the title of one of the submissions, you’ll be taken to the full submission that includes the accept/reject buttons. That’s how it works currently, so nothing there.

Would having a “review submission” button or something similar help clarify that more?

@18percentgrey There’s definitely a problem on our end with the individual submissions that don’t load for you (the blank pages). The team will be taking a look at this first thing in the morning tomorrow when our work week starts.

Thank you for helping debug this, and for your patience!

1 Like

cc @matt okay nope now we actually found the problem. :slight_smile: well the symptom.

clicking the test post~~~ https://write.as/s/nvhdwhv31eo20
via:
https://write.as/the-mind-unchained/

menu: submissions

https://write.as/me/c/the-mind-unchained/submissions

### [well cj answered me after i checked my email and deposited nuggets of progress...](https://write.as/s/nvhdwhv31eo20)

#### October 11, 2020 By [omar testing](mailto:modals@f00.tech) Awaiting Review

click: url well cj answered me after i checked my email and deposited nuggets of progress…

=

screen is blank.

literally just blank.

in -

https://linkmeow.com/screenshots/2020/oct/submitas/more%20for%20submit.as.discuss.write.as.thing/also_.txt

Haha. :smiley: I think I tried everything.

ooh. okay cool, i was like scratching my head over here… im pretty thorough LOL. cool thank you shall wait without waiting.

and actuallly yes- a review submission button would be rad. i find myself getting tripped up in the write.as UX flow actually, kind of weird, but there are a few sticky points that require me to have 3 or 4 browser tabs open per blog to execute my process, and i’d like to streamline that, because I do a lot of writing.

[even saving one click, a whole synack ack , etc etc approve, load, click back, copy to my social site, copy to facebook, click back make sure no typos AGAIN, etc- usually fix one thing then its done, but

there are eh i understand not wanting to do anything to the UI. perhaps we can throw something with a batch editor level granularity at a glance n the sea monster codebase thing ? i forget the name :slight_smile: @matt

well, @matt I think somehow my account got locked on permissions flow for actually having read/write access to some element of internals.

as evidenced by the weird behavior previously discussed around submissions, my use of VPN, something perhaps with fail2ban or grsec, etc… inside the servers security config.

nothing else would prevent a fully functioning user implementation with known good browsers (as a fellow engineer), from operating, i mean the data flow all works except its just not showing up. sounds like permissions.

i will leave it at that since i dont have ssh, and that is my best guess, after playing with it today, and sleeping on it some.

see this screen of a test submission url appearing blank when i load it and attempt to view source, with no other errors generated in the process. isn’t that interesting? cc: @cjeller1592

Okay, I believe we solved the issue – could you try opening those submissions again, and let us know if that works?

For a little background, there was a single bug at play here, but this (ancient) part of the app didn’t have any error logging (including any error message shown to you, the user). So we had recently introduced a small bug that only affected a few users, and then didn’t log any errors on our end, and didn’t show you that anything was wrong, either.

All of that is now fixed on your end, as well as ours! So this shouldn’t be an issue going forward.

1 Like

sometimes you have to put the new unbroken possibly broken shit in the wild, to test something that hasnt been done before. i understand conceptually, let me look…

:wink: thanks . yes, you did gauge how my brain works. all i want is it to work haha, ever really. the rest of the time im not at a computer.

yup it all works. what a relief. thank you. i have so much to get done with this tool. ! thank you for making it. i dont know if you see this and i bet you do since you did all this- there is nothing else like your offering out there right now. :slight_smile: just wanted to recognize the power of an original idea… and even if so much not accurate nothing is original, tis an idea with a lot of functional utility, and potential to modularize itself into all manner of helpful things and places.

i see what write as can look like in 30 years or so, but im waxing now. which means it is lunch.
impotant part is below: (immediate in context of me needing help with write.as) –

(my blog dns redircts dont yet all 4 ways) and that has been driving me nuts since day 1, and i still need help with that humbly please. :slight_smile: