submissions are not sent to my email adress

Title says it all. Before it used to work.

Sorry for this issue – we had a pretty bad bug that was capturing submissions, but not connecting them to the original prompt. This is fixed now!

Were you just testing things out, or did someone try to submit something to you? If you know of any submissions that were sent to you and know some sample text of what they contained, let me know and I’ll manually connect them to your blog.

I was testing it myself, and I did a test a few minutes ago: it didn’t went to my mailbox.

But I changed my main adress when I went back to blogging. Maybe it’s the cause? I do not have access to the old email account.


Looking at our logs, it seems like you might not have notifications enabled.

So you’ll want to go to your Submissions page, and then click the “Not watching” button near the top-right corner of the list. Once you do, it should look like this (the button should say “Watching”):

OK I enabled watching, but I still don’t get the submissions (checked the spam folder).

Are the submissions sent to the main email account? Mine is

(I enabled notifications as per described)

Ah, you might need to add an email address to your team profile – it’s separate from your account. Sorry for the confusion.

To do that, you’ll go to your team’s Settings page from the tab at the top of the page, then go to the Profile section. There, you can add an email address that’ll be used for the notifications.

I don’t know where my team profile is…

Is this it?

If it is, I don’t have a subscription and I don’t plan to…
But that’s fine, I can let my email adress in my about page as a way to contact me, it’s the most important prompt by far.

Isn’t there another way?