fails to load one or more photos intermittently


I have been experiencing intermittent issues with uploading photos. As this is the prime reason for me using, to share photos, and a few words, while retaining ownership of the photos, it is becoming a show stopper for me.

I have attached some screenshots showing both failures and success. I have used Wireshark to capture the upload sequence, and it looks like the host stops sending acknowledgments for a period before sending all at once. It has been a while since I decoded TCP/IP network packets, but I have saved the captures if that is helpful.

I tried MS Edge as well to verify it fails sometimes there too.

I also note that the tick is not always displayed for a successful upload (Screenshot 2024-03-24 092657.png).


Environment - Starlink, Windows 10, Firefox and MS Edge

Screenshot 2024-03-23 175437

Does it fail to upload the same image over and over? If it does, check the file size. has a max image size limit for uploads, I think it starts to fail around 12 MB.

Thanks. It is not the image size, which is what I thought the problem might be. In the past I tried reducing the image size that failed to upload, and it still failed to upload. If the size is larger than the allowable limit, you get a warning, and in one of the screen shots, you can see images with a X that are too large.

Personally, I think it is some kind of throttling issue. It can occur when I upload a single photo, or multiple photos. I do not think it occurs until I have uploaded, successfully, one or more images.

Very puzzling and frustrating.


Understood. Was hoping it was just the image size issue. Hopefully the issue will get resolved soon.