Running WriteFreely on a VPS

Hello Matt, I’m not able to run writefreely on my VPS. This is what I’m getting….

PNG image

Hi, what seems to be the trouble? Looks like it started up correctly on port 8080.

Do you have a reverse proxy set up, so you can access the site from outside of your VPS?

Thanks for your quick response. Yes I did. Although I’m not a programmer and I followed the steps mentioned below :arrow_down:

This is the output I’m getting on the IP

It’s really simpler to get started without the mysql first to see if you can get it running. Which it seems to be running. Also the documentation here have all the settings you need:

If you are first time using a vps, I would suggest to get a normal test site on nginx. Once that’s up and running try to install writefreely without a database. You would only need a database in a multi user setting.

Right now I cannot see any port open on your server, so you might have a firewall that block everything… Are you using Digital ocean and what OS are you using? Digital ocean have very good tutorials to get you starting running your own nginx instance.