[RESOLVED] iOS App crashes at launch

I’m trying to use the iOS app on iOS 16.1.1 and it crashes persistently at launch time. I tried to re-install the app but it doesn’t help. Any idea around what might be causing the crash?

This happened to me today. I force quit all apps on the phone (to clear memory - just in case), then restarted it. The app crashed the first time I started it after that, then didn’t crash the second time I started it.

I installed it on my iPad and it worked first time - no crash.

Tagging @angelo to see if he might have some insight on this.

Interesting. @pepicrft and @macalba, can you confirm what version of the app you’re using?

It’s “WriteFreely v1.0.13 (build 688)”, purchased and downloaded yesterday from the App Store.

I’m sorry for the delay here. I looked at what Apple provide us as far as crash reporting and don’t see anything, but that’s not always an accurate tool (we don’t use any third-party libraries for this kind of thing, which can be more reliable in reporting issues).

@macalba has it been running normally for you after that first crash?

@pepicrft could you make sure you’re running the latest version of the app?

Yes, it’s now running normally.

I have copied the crash reports off the phone via the iMazing app onto Mac. I can send some or all of them to you if you let me know how/where.

For example, the first lines from one of the reports:

Incident Identifier: 8826142B-DC6F-4554-AAE3-26511EE27F95
CrashReporter Key: e1b5babc3faea00302a321851da13b96a11a6e93
Hardware Model: iPhone13,3
Process: WriteFreely-MultiPlatform [13964]
Path: /private/var/containers/Bundle/Application/CA17A9D5-8859-43A8-9B82-A78D30454238/WriteFreely-MultiPlatform.app/WriteFreely-MultiPlatform
Identifier: com.abunchtell.WriteFreely-MultiPlatform
Version: 1.0.13 (688)
AppStoreTools: 14B44
AppVariant: 1:iPhone13,3:15
Code Type: ARM-64 (Native)
Role: Foreground
Parent Process: launchd [1]
Coalition: com.abunchtell.WriteFreely-MultiPlatform [2170]

Date/Time: 2022-11-26 13:10:48.0378 +1100
Launch Time: 2022-11-26 13:10:46.5860 +1100
OS Version: iPhone OS 16.1.1 (20B101)
Release Type: User
Baseband Version: 3.07.00
Report Version: 104

Exception Codes: 0x0000000000000001, 0x00000001c5dcc7cc
Termination Reason: SIGNAL 5 Trace/BPT trap: 5
Terminating Process: exc handler [13964]

Triggered by Thread: 0

Thread 0 name: Dispatch queue: com.apple.main-thread
Thread 0 Crashed:
0 SwiftUI 0x1c5dcc7cc 0x1c5dbf000 + 55244
1 SwiftUI 0x1c5f68e34 0x1c5dbf000 + 1744436
2 SwiftUI 0x1c5fa54dc 0x1c5dbf000 + 1991900
3 SwiftUI 0x1c60470ec 0x1c5dbf000 + 2654444
4 SwiftUI 0x1c6047be4 0x1c5dbf000 + 2657252
5 SwiftUI 0x1c5e2fb00 0x1c5dbf000 + 461568
6 SwiftUI 0x1c5e5d0f0 0x1c5dbf000 + 647408
7 SwiftUI 0x1c722c8c0 0x1c5dbf000 + 21420224
8 SwiftUI 0x1c5e67da4 0x1c5dbf000 + 691620
9 SwiftUI 0x1c6bb1170 0x1c5dbf000 + 14623088
10 SwiftUI 0x1c6bb3430 0x1c5dbf000 + 14631984
11 SwiftUI 0x1c5e8bef8 0x1c5dbf000 + 839416
12 SwiftUI 0x1c5fd6fa0 0x1c5dbf000 + 2195360
13 UIKitCore 0x1c4612564 +[UIView(Animation) performWithoutAnimation:] + 76
14 SwiftUI 0x1c6bb1bcc 0x1c5dbf000 + 14625740
15 SwiftUI 0x1c5e8bef8 0x1c5dbf000 + 839416
16 SwiftUI 0x1c5fd6fa0 0x1c5dbf000 + 2195360
17 UIKitCore 0x1c4612564 +[UIView(Animation) performWithoutAnimation:] + 76
18 SwiftUI 0x1c6bb3598 0x1c5dbf000 + 14632344
19 SwiftUI 0x1c5ea7e30 0x1c5dbf000 + 953904
20 SwiftUI 0x1c67d97fc 0x1c5dbf000 + 10594300
21 SwiftUI 0x1c5dd8850 0x1c5dbf000 + 104528
22 SwiftUI 0x1c5dcb1c0 0x1c5dbf000 + 49600
23 SwiftUI 0x1c5dcb0d4 0x1c5dbf000 + 49364
24 SwiftUI 0x1c5dcb368 0x1c5dbf000 + 50024
26 CoreFoundation 0x1c243e2d0 __CFRunLoopDoObservers + 532
27 CoreFoundation 0x1c249fc7c __CFRunLoopRun + 1048
28 CoreFoundation 0x1c24a4ed4 CFRunLoopRunSpecific + 612
29 GraphicsServices 0x1fb7a2368 GSEventRunModal + 164
30 UIKitCore 0x1c49833d0 -[UIApplication _run] + 888
31 UIKitCore 0x1c4983034 UIApplicationMain + 340
32 SwiftUI 0x1c5f90014 0x1c5dbf000 + 1904660
33 SwiftUI 0x1c5ef116c 0x1c5dbf000 + 1253740
34 SwiftUI 0x1c5eda4bc 0x1c5dbf000 + 1160380
35 WriteFreely-MultiPlatform 0x10065cc98 0x100658000 + 19608
36 dyld 0x1e0b0c960 start + 2528

Oh, this is excellent, thanks @macalba! I’ll need a little bit to translate those memory addresses into symbols but this could be very helpful indeed.

Glad to hear it was just a one-off for you.

@macalba @pepicrft I think I’ve managed to reproduce this:

  1. If it’s already installed, delete the app from your phone
  2. Install the app from the App Store
  3. Launch the app
  4. Note that it creates a new local draft for you, then navigates back to the Drafts list and, because the new draft is empty, deletes it
  5. Force-quit the app (or wait until iOS terminates it in the background)
  6. Launch the app again
  7. Note that it creates a new local draft for you, then navigates back to the Drafts list, then crashes

Navigating back to the Drafts list on creation of a new post on launch is a regression; I’m tracking this crashing bug here and I’ll request an expedited review from Apple when I get a fix up.

1 Like

I’ve submitted an update that temporarily removes the feature launches the app to the editor (either to the last draft you were working on, or a new local draft) to prevent the app from crashing on launch.

1 Like

WriteFreely for iOS v1.0.15 build 700 has been submitted for review approved for sale. It brings back the feature that launches the app to the editor and cleans up a couple of other little glitches as well.

I’m marking this as resolved, but please do let me know if you see any issues when the update hits the App Store!