Problems with Federation-URL and other URLS

Hello,

I have installed Writefreely on my own server with Debian 10, Apache, MySQL and PHP8.1.

Everything seems to work fine, but unfortunately, I have problems with federation. Although I have configured writefreely to work with a reverse proxy (https://regenpfeifer.de), my federation name shows up as: @regenpfeifer@localhost:8080. Of course it should read as @regenpfeifer@regenpfeifer.de

Unfortunately, it seems, that I have similar problems with the URLS, of my posts. They are also all linking to http://localhost:8080/
I would very much appreciate any hints how I have to configure my settings (maybe the Apache VHost?) in order to get this working.

Yours, Regenpfeifer

I can provide my Apache VHost here:

<VirtualHost *:80>
    ServerName regenpfeifer.de
    ServerAlias www.regenpfeifer.de
    ServerAdmin my@email.add

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    RewriteEngine on
    RewriteCond %{SERVER_NAME} =regenpfeifer.de
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

<IfModule mod_ssl.c>
<VirtualHost *:443>
    Protocols h2 h2c http/1.1
    ServerName regenpfeifer.de
    ServerAlias www.regenpfeifer.de
    ServerAdmin my@email.add

    ProxyPreserveHost On

    ProxyPassMatch ^/.well-known/(webfinger|nodeinfo|host-meta) !
    ProxyPass / http://localhost:8080/
    ProxyPassReverse / http://localhost:8080/

    Header always set Accept "application/activity+json"

    <Directory  /var/www/writefreely>
	Options Indexes FollowSymLinks MultiViews
	AllowOverride None
	Order allow,deny
	allow from all

	RewriteEngine on
	RewriteRule ^(login)$ http://localhost:8080/$1 [P,L]
	RewriteRule ^(save)$ http://localhost:8080/$1 [P,L]
	RewriteRule ^(results)$ http://localhost:8080/$1 [P,L]
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    Include /etc/letsencrypt/options-ssl-apache.conf
    SSLCertificateFile /etc/letsencrypt/live/my.domain/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/my.domain/privkey.pem
</VirtualHost>

</IfModule>

That URL is set in the /writefreely/config.ini
Line 28, under the [app] section.

Right, you’ll want to set the correct domain name in the [app] section of your config.ini. That’s what WriteFreely uses for things like the fediverse ID / domain.

Thank you, @matt and @atyh,

I had previously tried to set the URL in the [app] section, but I forgot, that I had to restart the writefreely-service, I only restarted the apache. So this didn’t work. Now I have set the correct URL-entry and restarted writefreely - and everything works fine!

Thank you very much!