Posts turn into scrambled, incomprehensible text


I purchased your pro subscription, but so far I have been encountering many, many issues.

One issue I have been having - when I publish a post, it automatically seems to encrypt the text and turn it into an incomprehensible garble. Like this:


Another issue I have is that adding images never works. I can add an https link in images (for example from imgur or from the image storage section on this site), but all it does is display a link. I can never get it to display an actual image. So far, adding images works, but I have to drop them into the posts where it says “drop photos”.

Is there any way I can un-scramble scrambled posts?


Hi, I’ll take a look at what’s causing this. First, it sounds like you’re using the Rich Text editor… Did you drag and drop an image directly into the editor, instead of the “drop photos” section?

Heya Matt,

That’s right, would you recommend not using that?
Any way to drag and drop images works, it works even if I don’t drop them into the “drop photos” section. It just never works with the links (I watched your tutorial videos).

Is there any chance scrambled posts can be recovered?


Rowan, if you drop an image directly into the editor, despite it showing up in the editor, it turns into that garbled text once you publish the post. The garbled text you’re seeing is the raw data of that image – and if that image is large, it could squeeze out other text in your post and unfortunately make it unrecoverable.

Sorry for this issue – it absolutely shouldn’t happen, and I’ll work on a fix today to make sure it doesn’t happen in the future.

But to correctly upload images, you’ll always want to drag photos into the section at the bottom. Otherwise, to insert external images like ones from imgur, you’ll find that option by pressing Insert > Image from the toolbar in the editor.

Ok, makes sense.

I did use the correct process to insert an image though. (Not this time, I mean before) Still didn’t work. Thanks for the quick reply.

What exactly happened when it didn’t work? Can you share the link to a post, either here or in a private message? Maybe I can help figure out what’s going on.

I’d choose: “insert image”, then in the https field insert something like “” (this isn’t my image, just a random one I picked now to illustrate the point), add a description, for example “caption”. Then when I hit enter, I just get that word “caption”, and not the actual image.

When I use the other method with, I’d upload the image there - drop the files in the “drop files to upload” box, click on “photos”, click on the image in question, grab the code below the image, and insert it (albeit) in the rich text editor, not in the code. It just shows up as the code, not as an image.

I also tried grabbing the direct link of the image on, like so: “” and try the “insert image” box, but the same thing as before happens (it shows up as a caption). I did get it to work once or twice at first, but for some reason it just quit working.

So the trick is that you need to use the direct URL of the images to get them to embed correctly.

If you want to use an image from imgur, you’ll want to:

  • go to that link
  • right-click on the image
  • select “Copy image address”

You’ll then come back to, press Insert > Image, and paste that text in the URL field. Once you press Enter, you should see the image show up correctly in the editor.

As an aside, Imgur is a supported rich-embed provider, so you can also insert that Imgur gallery URL on its own line, and it’ll automatically show you a nice preview once you publish the post (as a Pro user).

For, it’s true the code given there is for the Plain Text editor, so it won’t work by pasting that code into the URL field. Instead, you’ll repeat the process from Imgur: right-click on the image itself in, then paste the result in the URL field. The address you shared is actually the image’s webpage, not the image itself.

Awesome, ok I get it.
Thanks for explaining it to me, I’m a noob after all. Sad about my disappeared post though. Looking forward to the fix.

Just a heads up that this is now fixed on! Will also be fixed in WriteFreely in the next major release.