New local posts take time to appear on device after publishing

Hey @angelo I have question on released writefreely app. I am using anonymous posts to let me share edits between my iPad and iPhone. There seems to be a lag from writing and publishing the post to anonymous and then seeing it. Sometimes minutes although it could be my network here in Vietnam. It’s not like that if I just use the web app to post to anonymous. I wish somehow we could have iCloud storage to share unpublished posts between instances. integration from the earlier post I’m voting up too :grinning:. Thanks for the client. Using it on both my iOS devices.

Hey @mpmilestogo, thanks for using the app!

When you say that you see a lag between publishing an anonymous post from your iOS device to seeing it, do you mean seeing it on the other iOS device, or on the web?

On the iOS device. I see it almost immediately on the web. If I write a post and publish to anonymous and then look on the same device the post does not show up but if I go look at the anonymous posts on it’s there already. Sometimes a minute or so goes by until the post is visible on the same iOS device I created it with. I’ll try viewing on my other iOS device too later.

Hi @mpmilestogo, that’s unexpected — since you’re creating the anonymous post on the device, it should be available immediately, since it’s also locally cached. I’m going to split this off into a new topic to continue the conversation!

@mpmilestogo, could you provide me with some information to help me investigate this issue?

  • What version of iOS are you running? Open the Settings app, go to General > About, tap Software Version and let me know what it says — for example, on my phone, the current version of iOS is “14.1 (18A8395)”.
  • What version of the app are you running? From the post list, tap on the Gear at the bottom-left of the screen, and just under the “Settings” title it will report the installed version — for example, the current shipping version is “v1.0.0 (build 359)”.
  • It sounds like you’re logged in to, could you confirm that’s correct?

Finally, could you give me step-by-step instructions on how I can reproduce this error? Something like:

  1. Tap the new post button in the post list
  2. Write a test post in the post editor
  3. Tap the menu button at the top-right of the post editor
  4. Tap “Publish…”
  5. Tap “Anonymous”
  6. Tap “< Anonymous” at the top-left of the post editor to go back to the post list, notice that the new published post isn’t at the top of the list

That would be really helpful in diagnosing what’s going on!

Hi. I am using the latest version of the app in the App Store. I believe version 1.0.0 build 359. I’m running iOS 14.1 on my iPhone. Here’s the sequence which occurs

  1. I write a new post in the editor and publish to anonymous. The article does not show up immediately but if I go to in mobile safari it’s there.
  2. This does not happen 100% of the time but often if I open the app on my iPad Air running same version I’d writefreely app the app does not immediately have the anonymous post either yet it’s in safari.
  3. It often takes a minute or so to get the anonymous post in the app but it appears immediately on the web.

Hope this helps!

I’ve been looking at this issue, and I’d like to make sure that we’re experiencing the same thing. Can you try the following for me?

  1. Launch the app on your iPhone. If it doesn’t launch to a new local draft, go to the list of posts and tap the New Post button at the top-right of the screen:

  1. Type out a test post and publish it to Anonymous. Across the top of the editor, you should see a back-navigation button < Anonymous (in my screenshot, it shows “Drafts” instead, because I’m publishing to a WriteFreely instance, not, a PUBLISHED badge, and the menu button:

  1. Tap < Anonymous to go back to the list of Anonymous posts and you should see the test post at the top of the list:

:warning: If you don’t see it here at this point, make sure you’re in the Anonymous list and not another blog in your account!

  1. Launch the app on your iPad. If you don’t already see the post at the top of your Anonymous list, tap the reload button at the bottom-right of the list:

  1. After the app fetches the content from the server, you should see the post appear at the top of your Anonymous list:

:warning: If you don’t see it here, make sure you’re in the Anonymous list and not some other blog in your account!

Let me know if this works the same for you as I showed in these screenshots.

Hi! This is exactly my workflow. When I do these steps as you outline, the anonymous draft does not show up for me in the app but it is present on the web immediately. If I hit the update button, nothing syncs to the app sometimes for minutes. If I force close the app and then return sometimes, not always, the anonymous post will show up. Other times it takes a few minutes to show up.

I’ve followed your instructions many times step by step and it’s truly random yet each time if I go to the web page and view anonymous posts it’s there but not on the writefreely app.

I’ll continue to test and update and try on different WiFi connections here and get back to you. My apartment WiFi is usually okay but I will go to a coffee shop here this morning and try on their WiFi.

Thanks for confirming these steps, @mpmilestogo! It’s definitely unexpected that the new Anonymous draft isn’t at the top of the post list. I don’t think it’s related to your network connection — if that were an issue, it wouldn’t be showing up on the web immediately (or at all).

Let’s try something a little different:

  1. Put your iPhone in Airplane Mode.
  2. Launch the WriteFreely app. If it doesn’t automatically load a new local post in the editor, go to the post list and tap the New Post button at the top-right of the post list screen.
  3. Create a simple test post with a title and a few words in the body.
  4. Without publishing the post (i.e., it stays LOCAL), tap the < All Posts (or < Anonymous, or whatever applies) back-navigation button at the top-left of the editor to go back to the post list.
  5. Tap the < Back button at the top of the post list to see your list of blogs.
  6. Tap on “All Posts” to see a list of all your posts across all your drafts and blogs.

Because the All Posts list sorts posts by the date created, newest first, the (local) post you just made should be at the top of the list when you go back. Is it there?

:warning: Don’t forget to take your phone out of Airplane Mode after testing this.

Hi. I just tried this and the post shows up immediately in all posts with my phone in airplane mode. I followed your steps above.

Okay, great! That’s progress. :slightly_smiling_face:

Let’s also check what happens if you don’t put your phone in airplane mode, but otherwise follow the same steps (i.e., steps 2 → 6). Does the app still show the new local post at the top of the All Posts list?

Hi. Just tried this. The local post shows up at the top without putting phone in sidplane mode.

That’s really good news! This means that, at least as far as the way the app works locally, the network isn’t affecting performance in any way.

Let’s try this now:

  1. From the “All Posts” list, tap on one of the local test posts you made — either the post you made with the phone in Airplane mode, or not in Airplane mode, it doesn’t matter. If you deleted those local test posts, just follow steps 2 → 6 again, and from the “All Posts” list, tap on the new post to load it in the editor.
  2. Before doing anything, confirm that the post is LOCAL and that the back button at the top-left of the editor says < All Posts. If not, stop here and let me know.
  3. Tap on the Menu button at the top-right of the editor (a circle with three dots in it). In the menu that pops up, tap Publish…; this will open the Publish to… sub-menu.
  4. In the Publish to… menu, tap Anonymous to publish this test post as an anonymous draft. The editor menu should close, the LOCAL status should switch to PUBLISHED, and the back button should still read < All Posts. If that’s not the case, stop here and let me know.
  5. Tap the < All Posts back button to go back to the “All Posts” post list. The test post that you just published should be at the top of the “All Posts” list, with an Anonymous tag above the title. If it’s not, please let me know!

Hi. It all works. Now the test post is published as anonymous and shows up. I do not see the earlier problem at all

Excellent! I’m glad that it’s working.

Here’s a high-level explanation of what happens in the app:

When you tap the new-post button, a blank post is created with a LOCAL status and is added to the local database on your iOS device. The change in the database is picked up by the list view, and so it adds the new post to the top of the Anonymous list (called Drafts, if you’re logged into a WriteFreely instance instead of, which is included in the All Posts list.

The app also sets this new post as the “selected” post from the list, which loads it in the editor. If you don’t make any changes and navigate back to the list of posts, the app does a little cleanup and deletes the empty local post.

If you do make changes, then publish the post, the app changes the status of the post to PUBLISHED, and changes the list it should show up in if you publish it to a blog instead of Anonymous/Drafts. You should always be able to find it in All Posts, since that’s a list of, well, all of your posts, but otherwise it’ll only show up in the list you published it to.

On launch, or if you tap the reload button, the app will fetch updates from the server, but otherwise it doesn’t change the fact that the post you wrote continues to exist in your iOS device’s local database of posts.

Hope this helps! I’m going to mark this thread as resolved, but don’t hesitate to open a new thread and tag me in it if you encounter any other issues with the app. :slightly_smiling_face: