Markdown Formatting Not Carrying Over to Emails

I’m wondering if it’s just my email or my email account or my browser that has this issue, but if you look at the email in the screenshot below, you can see that the line breaks are not formatted correctly. Is there any way to fix that? Do I have to put in extra spaces in my Markdown text to make it show up correctly in the emails?

Just for reference, this is a screenshot of the original post. You can see that the line breaks don’t carry over into the email.

Hmm, this is a bit tricky. I imagine this has something to do with how we parse emails, but I’ll need to do some research.

Just so I know, are you sending emails in plain text format, or HTML?

Hey @matt, thanks for reminding me about this thread. The emails I’m talking about here are the emails I receive directly from

I did some testing on my own and found that it seems to be dependent on which email provider you use to subscribe. They way I tested it, is by subscribing to my own blog using an and Protonmail email address.

The email I received in Outlook had the issues with formatting (refer to screenshots below). Note how the word “Tags”, which was on a separate line below, was moved up right to the end of the previous line.

The email I received in Protonmail looked perfect (refer to screenshot below). Exactly like how I would expect it to appear.


I just noticed exactly the same thing with a new blog I’ve created, sending HTML emails.

When viewing in I get exactly the same problem as shown above.
When viewing exactly the same email (i.e. from the same inbox) in the MS Outlook desktop application it appears correctly and as expected.
When viewing in Fastmail there is an unexpected line break after every URL, that may be a separate issue though.

This looks to be some cross between a known bug and a deliberate feature in Outlook, based on this Microsoft article: Line breaks are removed in posts made in plain text format in Outlook

By default, the Auto Remove Line Breaks feature in Outlook is enabled. This causes the line breaks to be removed. Any two or more successive line breaks are not removed.

This is specifically talking about emails created in Outlook using plain text mode, but it seems maybe this is being applied to external emails as well?

1 Like