MacOS install, Pages error(s)

Installed the pre-compiled MacOS setup (to get a look at the admin side on the road to launching an instance) and everything in the Admin area appears to work except going to Pages, which just tosses up that “Server error” page.

(ETA: The default page links (About, Privacy) lead to the same error.)

Debug log:

ERROR: 2019/05/27 17:47:45 log.go:26: Failed selecting from appcontent: no such column: title

2019/05/27 17:47:45 "GET /admin/pages" 500 1.729443ms "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.1 Safari/605.1.15"

2019/05/27 17:47:45 handleHTTPErorr internal error render


Does it fix the error if you run:

writefreely --migrate


Hm. Nope.

What was the terminal output when you ran that?

Bix-MacBook-Air:writefreely_0.9.1_macos_amd64 bixmediocre$ ./writefreely --migrate
2019/05/27 18:59:32 Loading config.ini configuration...
2019/05/27 18:59:32 Connecting to sqlite3 database...
2019/05/27 18:59:32 Migrating to V1: support user invites
ERROR: 2019/05/27 18:59:32 log.go:26: migrate: table userinvites already exists

Yeah, the 500 error is happening because the V2 migrations haven’t run (this should happen on install, i.e. writefreely --init-db). Not sure how things got messed up so the migrations don’t work, though.

Either way, if you go into your appmigrations table in your database, insert a row where version is 1 and then run --migrate again, that should fix things.

I might need that in Captain Dummy talk. It’s been… a decade or more since I’ve had to mess with any of this backend stuff. (I could also just walk myself through a re-install from the beginning, which would probably lead to me getting into some weirdness I ran into the first time and didn’t leave posted here.)

Actually, I just tried a fresh install on Mac and the --init-db step failed. I think it was the same error you reported in a now-deleted post. So this looks like a bug we need to fix. If you want to file a bug report for this on Github, that’d be much appreciated.

The original error (FWIW, for whomever’s interested) was a failure on --init-db because it appeared to have a hard-coded local directory that doesn’t exist and couldn’t load the schema. I’d deleted the post because I ended up figuring out how to manually load the sqlite.sql file to create the DB. I don’t know if doing that causes the new error, or the new error is an entirely separate bug that exists in and of itself?