Let the Reader display posts older than 3 months

I have a WriteFreely site where posts are fairly rare. I just noticed today that the /read page is empty, even though the individual blogs have posts, and they show when I visit the blogs themselves. Upon digging deeper, I found that the Reader will only display posts not older than 3 months, and mine were.

It would be amazing if this could be configurable, and even more so if there would be an option to completely disable this time limit, and just display everything until we hit other limits like post count.

(Meanwhile, I’ll tweak my installation to remove the time limit, but it’d be nice if in the future, I wouldn’t need to maintain this little patch.)

Thanks for the feedback, @algernon! I’ve noticed the same thing, and we’re actually looking to switch to a total post count limit in the next release, v0.12. We’ll update everyone here when that pull request is open.

On a related note, I’m curious if you’d like to have control over the per-author limit on the Reader page. Right now, WriteFreely only shows up to 5 posts from a single author there, to be sure no one can fully take over the Reader feed. As an admin, would you like to be able to adjust or turn off that limit?

I’d love to, including having no per-author limit.


Awesome, great to know. Thanks!

This is now in progress here:

Will probably address the per-author limit next.

This is merged now! It’ll be in our next WriteFreely release.

We’ll address the per-author limits in another set of changes, once we can figure out how to roll this into another configuration setting.

1 Like