Issues running WriteFreely on a Raspberry Pi


I’m trying to set up WriteFreely on my Raspberry Pi 4. I installed it by downloading the arm7 tar ball from the releases page. The installation succeeded, the setup was smooth and I didn’t see any issues there. I was also able to get it up and running where I could see the page, login and type stuff. But when I hit publish, I’m getting the following pop up error:

Failed to post. Please try again.

I check the terminal to see if there are any logs, and I find this:

ERROR: 2020/01/06 17:08:16 posts.go:515: new post: is user suspended: User doesn’t exist.

Not sure why it says User doesn’t exist because I went through the Config wizard and created a user when asked to do so.

Here’s what my config looks like:

hidden_host          =
port                 = 6767
bind                 =
tls_cert_path        =
tls_key_path         =
autocert             = false
templates_parent_dir =
static_parent_dir    =
pages_parent_dir     =
keys_parent_dir      =

type     = sqlite3
filename = writefreely.db
username =
password =
database =
host     = localhost
port     = 3306

site_name          = rrajath
site_description   =
host               =
theme              = write
editor             =
disable_js         = false
webfonts           = true
landing            =
simple_nav         = false
wf_modesty         = false
chorus             = false
disable_drafts     = false
single_user        = true
open_registration  = false
min_username_len   = 3
max_blogs          = 1
federation         = true
public_stats       = true
private            = false
local_timeline     = false
user_invites       =
default_visibility =

I also tried following this guide and I was running into other “Go” related issues.

Has somebody installed write freely on a Raspberry Pi? Can somebody help me out? :slight_smile:

Bump! :slight_smile:

Hey @rrajath! This shouldn’t be anything related specifically to the RPi 4, but I’d imagine it’s something either related to the database connection, being logged in, or that user creation during the setup process.

Either way, I’d start by making sure that first user exists, and that you’re correctly logged in to your instance before publishing (that is, other pages on your instance should work fine).

For more detailed help, the community might be able to offer more guidance. Otherwise we’re always happy to do hands-on WriteFreely support for a small fee. Just let us know if you’d like to go that route.

Hey @matt, I’m facing the same issue on Mac as well. I used sqlite as the backend during the config setup. I tried the following things:

  • I opened writefreely.db in sqlite with sqlite3 writefreely.db
  • I verified that the users table has the user I created
  • I found that the accesstokens table is empty even after I login

I don’t think there’s an issue in connecting to database because I’m able to log in successfully.

that is, other pages on your instance should work fine

I don’t see any other pages when I run writefreely and the first post I’m creating shows me that error. Is there a sample post that comes with the setup? Because I checked the posts table in writefreely.db and that’s empty too.

Any other way to debug this? Logs? Debug flag while running writefreely on command line?