Is it possible to disable url & picture limits?

I often run into the issue that I edit my texts (adding new stuff) and then get an error message saying “failed to submit post, please try again”.

I figured out that this happens when I reach a certain number of urls and/or images in my post.

A workaround is to split my post into two, but then all links to paragraphs in the text are broken. I can fix the links in the text itself, but shared links somewhere else on the web will stay broken.

I already asked the people running my blog if they can change the settings, but they haven’t replied yet. Maybe if I tell them where exactly those limits can be changed they will respond to my question.

Hey @paulakreuzer, we don’t have anything built into WriteFreely that limits the number of URLs / images in a post. So it could be that the instance is running a different version of WF that adds these limits, or something else is going on.

To rule out the latter, we could see if the API offers anymore information. Are you comfortable with browser developer tools? If not, no problem, I can walk you through the process.


Yes please walk me through it. :slight_smile:

Sure thing:

  • First you’ll navigate to the editor page on your instance
  • Now open the Developer Tools screen by pressing Ctrl+Shift+J (or Command+Option+J on Mac)
  • Select the Network tab

Now that you have everything ready to go, you can try publishing:

  • Enter the full text of a post that has failed before
  • Press the Publish button in the editor
  • Assuming it failed, you should see a new entry in the Developer Tools window
  • Select the first row in the list – it should open up a small window pane next to the list
  • Select the “Response” tab in that window pane, and share the text you see there over here

With that information, we can at least we can get a small idea of what might be happening.

1 Like

Thanks. Here is what I get:


code: 500

error_msg: This is an unhelpful error message for a miscellaneous internal error.|

Response payload

1 {“code”:500,“error_msg”:“This is an unhelpful error message for a miscellaneous internal error.”}

I guess that is - just as it says - not very helpful, @matt?

Hi @paulakreuzer, that error is definitely on their end then. Were you able to get in touch with the people running your blog? I see the topic is still empty but maybe they messaged you personally about it.

1 Like

Sorry, I’ve been spending my time with different things after August. I finally posted in the privacytools forum too. Let’s see if I get an answer this time.

Meanwhile I started a blog on wordsmith social and copied one of the problematic posts over there. Interestingly there I don’t get an error message and at first I thought everything worked fine, but I just realized that the last part of the post is just cut off. The post - the shortened version - is 5165 words, so that would be a strange cut off for a word-limit.

So this might not just be a privacytools issue after all.

PS: I just realized that you can link to a section of the post simply with [Chapter](#Chapter) instead of [Chapter](https://url#Chapter).
I removed all unnecessary urls and now the longer version of the post can be saved and fully displayed on both instances. So it seems to simply be a limit of https urls.

No worries @paulakreuzer! I am glad your post can now be saved and fully published on both instances. It is still an issue that needs further inquiry.

We can try to get in touch with who runs Wordsmith and see if that instance is running a different version of WF that adds those url/picture limits. If so, then maybe privacytools is running something similar.

1 Like

Hi @cjeller1592, we do not run a modified release (at At the time we were running v0.9.1, we’ve just updated to v0.10. Not sure if that fixes this bug but I’ll try and check in a bit.

1 Like

It’s not fixed. If I copy my longest post (with lots of urls & pics) and try to save a draft with the text pasted in twice I still run into the same error message.
Atm I don’t run into the issue without trying to force it, but one day I probably will again, so thanks for looking into it. :slight_smile:

Thanks for clarifying @JonahAragon. We’ll have to look into things fuller. If anything comes up on our end we’ll be sure to push the changes to a new version.

@paulakreuzer, do you have the text of the longest post in question that we could use in order to test things out on our end? You could refer us to a URL or send us the bare text to

1 Like

Sure thing. This is the one.