Intro Divider (More...) typed vs. pasted

writeas

#1

When I type the <!—more—> code for intro divider on the main page, the two dashes auto-formate to the longer dash and thus do not pass muster. I have to copy and paste from Ulysses. Ideas? Am I missing something? Thanks!


#2

Hmm, sounds like maybe Ulysses is transforming them into a single dash? Our web editor shouldn’t be doing that…


#3

Thanks, @danielbowen, but nope, you’re understanding it exactly backwards. The editor (including here in the forum, and in write.as) auto converts two dashes in a row to “—“ instead of “–”. The first double dash I typed into the reply window for this forum, open in “Safari” on my iPad, the second two dashes I pasted from Ulysses).


#4

Ah, I think I understand now. So when you’re actually typing in the Write.as editor they automatically turn into that longer dash? If so, that sounds like a Safari feature that we probably don’t have much control over. I know some Mac apps do that – the feature is called “smart quotes” or “smart dashes”. Maybe there’s a way to turn that off in your Safari or keyboard settings? (I don’t have an iPad to test on, unfortunately.)


#5

“–” Ha! Brilliant! Smart punctuation toggled off on the iPad, and now I have dumb punctuation, which is smarter. Grin. Thanks, @danielbowen!

With abandon,
Patrick


#6

Haha. Excellent! Glad it worked :relaxed: