Help - My Anonymous post "jumped back" to older, outdated version!


Please help!

I have been working on a long anonymous post since yesterday.
During this time, I have published it tens of times and reviewed it again and again.
I didn’t save it to my blog, and only worked anonymously, since the post wasn’t ready yet.
An hour ago I even shared a link to a my colleague.

Few minutes ago I restarted my laptop and when I reopened the post,
it “jumped back” to a version from yesterday, and not even the last version from yesterday!
The post that I see now is only 350 words, but my last version, which I am hundred percent sure I have published for many times - was more then 1000 words ago.

I’m looking at, and it only show 12 records,
although I have published tens of times today!
The worse part is that all of those 12 records are from yesterday!
None of those version is even half of the full post that I have written.

Sorry for the drama, but this post is critical to my work and it would take me many hours to re write from scratch…
So Please, please tell me if there is anyway to recover the post since I’ve spent the whole day writing, designing, and reviewing it!

If you have the browser with which you wrote the post, try fetching data from the localStorage:

  1. Navigate to the page on which you wrote
  2. Press F12 to open developer’s tools
  3. Open console
  4. Paste in the following and hit Enter:
for(var i in localStorage)

You might or might not find the last revision. Perhaps localStorage is also polluted, but that’s one way to look for lost data.


Thank you for the answer.

I do have access to the browser from which I wrote the post,
but I am not sure from which page did I wrote.
Is there any other option but simply “” ?

I tried your solution with that URL, and it doesn’t seem to work.
I recieve many records, in which there is only one that contains my post,
but it is also outdated…it’s from 08/03/2020, and I need the versions from 08/04/2020.

I would be very glad to hear if you have any other solutions.
I understand that you tried to check If my local storage still have a version of the post,
but if I may suggest - what about the backend? or your database?
If my post versions are also saved to your DB, it is very reasonable that it would be recoverable from there…
I assumed that when I click “publish” it also saves to the server, not just to the client-side.

Sorry to hear that. I’m not the developer though – just trying to help. So that’s the best I know

Hi there! I don’t think there’s a way to recover the earlier version of your post — sorry about that! Were you using other devices when editing the post? Sometimes that has been a culprit too, where someone will have a draft still open on one device, open up another one, and have the outdated version. Again my apologies and let us know if there’s anything else anyone can do!


Thank you for the comment but the answer is no indeed. I was working on a single laptop for more then 10 hours.

I restarted the computer some when and when it came back on the post was gone.

I would be very glad if you could answer me:

  1. “Publish” does not save any copy of the post at the server side or DB? The post is only saved locally?! It doesn’t seem logical…

  2. When entering the “/posts” page, as I said, I only see 12 “early” versions of the post. Is it a bug? How many versions should be saved?

I thought this page simply contains all the versions of the post, but unfortunately discovered it is not correct…

So is it a bug or it simple works this way?

Thank you,


I’ve been noticing similar issues with the Safari browser in my iPad.

I’ve been changing my CSS a lot lately. Often after I save my changes, will process the changes but when I come back to edit CSS, the code will somehow have reverted back to my old code. Often I won’t notice until I save changes again and when I reload my blog, I’ll notice that some old customization has come back. That means I’ll have some new customization mixed in with some old customization I had previously removed.

Also, this morning I published a new post. After hitting Publish, the post wasn’t there. I refreshed a few times (both on my custom URL and my URL), but the new post never showed up, so I had to repost.