Error in running Writefreely on localserver


#1

I tried installing Write Freely on my local computer (Windows 10) & I selected SQLite with Federation Disabled. Everything else was done but when I type writefreely command to run it, it shows error ‘Database user or password not set’. What is the issue?writefreely


#2

Hi, this was a bug that was recently fixed – you won’t see the issue in v0.7, which we’re releasing today.

For now, you can get around this by setting a fake username and password in config.ini


#3

Okay, that’s cool! Let me test that out.
Another thing, I am really impressed. You have really created a service that enables people to speak out freely. Thank You! And please, do not stop!


#4

BTW, how can I edit the .tmpl files and provide a customized experience? I tried editing and saving them but it didn’t affect the end result.


#5

After editing them, you just need to restart the application to see the changes.

Note that any changes you make to the templates might be overwritten by future versions, so you’ll just want to carefully see what changed before upgrading. In the future, I imagine we’ll support a way to make customizations without them getting in the way of upgrades.


#6

Well, before that. I ran into another problem. When I try to create an account, it just gets into loading mode infinitely and the account is never created. Its just waiting for response forever. What is the possible fix?


#7

This is another recently-fixed issue affecting SQLite-backed sites – it’ll be fixed in v0.7 as well.


#8

By the way, what files in particular are you trying to customize?


#9

The homepage. As every writefreely service has the same welcome page. I wanted something different.


#10

Thanks, this is good to know for the future. :+1: