Dark Mode not working in Chrome 70


#1

Trying out dark mode (Toggle theme button) in Chrome v70, but it’s not working. The menu at the top changes and the body text color changes to white, but the background remains white. I can fix this with Dev Tools by disabling the white background CSS for the #writer textarea.

The CSS I had to disable looked like in-line styling (found under element.style). I disabled:

background: none 0% 0% / auto repeat scroll padding-box border-box rgb(255, 255, 255); and the dark theme worked!

I’m wondering if this is a bug or some weird extension or an issue with Chrome.


#2

Hmm, I’m not able to replicate this in Chrome 70. It could definitely be an extension issue causing this – we’ve seen it before with ones like Grammarly. Do you have that extension installed?

If not, in the developer tools, what is the class attribute of the <body> tag set to when in light or dark mode?


#3

Ahh, that was it. I had disabled it for a few sites (write.as included) but it seems it was still messing with the CSS. I disabled it globally and that fixed it. Thanks!