Custom URL : consequences

Hi there!

I created a blog and mentionned various ways of contacting me:

I’m about to change the URL to sfss.space

–> How do I modify the infos below?

Fediverse
@science-fiction-short-stories@write.as
Will become:
@blog@www.sfss.space
Right?

RSS feed
https://write.as/science-fiction-short-stories/feed/
Will become
https://sfss.space/feed/
(I guess)

Directly in your inbox
Is there a new mailbox generated?

Right now I have this mail adress:
Edited

Will it change? Also I didn’t really understood the mail system: is it an adress I can mention on my about page so people send mails to it? If so, how do I consult my emails?

Thanks!

So sfss.space is now live (but the old url too) and I can’t edit my posts or create new ones.

When I login to write.as, the url shown is the old one.

Hi @sfss! So editing and creating posts for sfss.space will still happen on the write.as url. That confused me too but I hope that clarifies things. You are also correct about the feed and I will get back to you on fediverse changes.

The email, however, is used for posting purposes only. You can send an email to that address and it will go to your blog as a post. I would keep that hidden and only share it with others who would also be posting to your blog.

@cjeller1592 hi and thanks a lot!

@sfss Your new fediverse handle will be @blog@sfss.space, just as you thought but without the www.

Screenshot%20from%202019-09-12%2012-16-32

3 Likes

@robjloranger yup indeed, thanks!

However, on Mastodon, I’ve noticed a problem: the link published by @readwriteas doesn’t work:

Leads to this page:
https://www.sfss.space/new-domain

Which gives a 404 because the correct URL is:

When you set your custom domain, did you enter www.sfss.space? If so try removing the www and posting again.

I’m assuming you set your DNS to point at sfss.space but told write.as that it was www.sfss.space.

I don’t remember but that’s a possibility. Okay I’ll change the domain.

Well indeed, it works now.

1 Like

:tada: awesome

glad you got it sorted out :slight_smile:

1 Like

@robjloranger hey there, me again! So everything works fine except one thing: I subscribed to my blog via mail to see if it works and I didn’t receive today’s post.

@cjeller1592 since you have a custom URL too: maybe you have an idea?

I published the mail code link before changing URL: maybe it’s the reason?

The emails take around 15 minutes to come through after the post is published. Did anything show up after that time? And you subscribed before today’s post was published right?

I would also recommend this guide here just to rule out every other option before we look to see if the domain is the culprit.

@cjeller1592 just made a test and posted: so I received the mail, but in my spam folder.

Maybe the email deliverability is not as good with an URL like xxx.space? (I don’t have a clue but I guess it could be an explanation) .

So the domain that it sends the email through is actually writeasletters.com, not your blog’s domain.

This spam issue has come up before. In that case Gmail marked it as spam sometimes and other times it did not (which is strange). We will look into it though. In the meantime make sure to report it as “not spam” and see if that does the trick for future posts.

Thanks! I did report it as “not spam” and I intend to publish a new post either tonight or tomorrow. Will report back here.

Ok so the new post didnt show up, neither on my main folder neither in my spam folder.

Might be related to the fact that I subscribed with a Gmail account.

Ah! I l often publish on “anonymous” and then move the post to the blog. Maybe it’s the reasin I didn’t receive last post?

Edit: yup that’s it!

Glad you got it working @sfss ! You are right, that workflow does not create a new email. We have run into this before. Copy and pasting that anonymous post into a new post for the blog seems to do the trick.

I will let you know if there are any developments that fix the issue though.

1 Like