Custom domain: "Your connection is not private" Chrome error

Trying to set up a personal blog with a custom domain that I purchased through Google Domains.

A very helpful Google Domains support person helped guide me step by step as to how to set up the domain with write/as, as I’m not very tech-savvy.

Here’s how it’s currently set-up:

I’ve also set up the Custom domain ini the Customize page as: redacted

However, whenever I visit, I get the Chrome privacy error that shows my certificate is invalid even though it isn’t. The Google rep recommended that I get help from write/as as everything on the domain side seemed to be working according to him.

Anybody know how to resolve this?

Just a quick reply that I changed the Custom domain field in Customize to “redacted”, as I noticed the previous URL was redirecting to a write[dot]as error page saying to add the proper URL. (Though I did this previously and was still getting the privacy error page)

Again, apologies to anyone who’s reading this and rolling their eyes – I’m super not-tech-savvy!

Welcome, @enabiah! Looks like everything was set up perfectly, but the HTTPS certificate did take a little time to generate on our end for your site. You’re all set now!

Note that you can choose whether you want to use the www version or not by setting your desired domain in your blog settings. But with the way you have it set up, if you choose the “” version, the www URL will automatically redirect to the non-www URL.

Hope that makes sense – and let us know if you need help with anything else as you get set up!

Y’all are wizards. Thanks so much, and I’ll keep all that in mind.

1 Like