Custom domain issue?

I will @support here but I dunno if they can help.

I added a domain to my blog around 32 hours ago of when I check the DNS propagation via a DNS propagation site it all points to IP address and such correctly. I have tried various VPN’s, devices, incognito modes, browsers etc…

All the time I get ‘ERR_TIMED_OUT’ error.

If anyone can help with this would be much appreciated!

Not sure why that happened – maybe too many failed certificate requests before the domain fully propagated. But you should be all good now :+1:

It works now, many thanks! Glad I delayed doing what I was about todo and delete the blog and nameservers entirely and try it again haha.

As for that other issue I was having dunno if you seen the update, at the moment I don’t need anymore than 3 blogs, but it would still be good to get it fixed in case of future, I need another blog, also worried it might cause issues elsewhere if billing possibly. I understand its the holiday period in a sense, so no rush on that as happy for now, just wanted to make clear I am happy with the 3 blogs for now.

I’m experiencing kind of a similiar problem: SSL_ERROR_INTERNAL_ERROR_ALERT

I added the domain: yesterday about 28 hours ago to point to new blog with DNS check seems to be correct for me.


This looks like a different issue… That shows up when a domain isn’t added correctly in Could you double-check the domain on that blog?

Oh sh… I’ve looked about 20 times today and I havent seen the typo. Had entered. Looks nice but… So, sorry for wasting your time…
It works now. Thank you

1 Like