Can't sign up, it says am a robot

I tried a few times to create an account but each attempt results in the page telling me that I am a robot. I tried waiting a little bit before sending anything, typing everything by myself but nothing worked.

Just another user, but assuming you cleared browser cache?

And/or try opening a private tab (without extensions or add-ons) to see if it’s a local thing. One other suggestion - try using a free VPN eg protonvpn gets you 10gb free a month - then setting your locale to a major country, eg the US or the UK or similar.

One last possibility - if you’re in a low/slow, patchy internet area your browser may be struggling to maintain a connection and repeating requests i.e. looking like a robot. Try signing up when you’re in an area with a strong connection.

Hope that helps!

Thanks! It was the browser cache. At least it seems to be that. :slight_smile:

1 Like

Heh - #cache got me plenty times, too :wink:

Such as; too many hours looking up weird range of questions from family and friends, for example :

  • land area of the vatican
  • alligator-jaw psi
  • am i a swiftie?

Next minute, Google :
“Are you human?”

. . .