Can't follow my blog over mastodon

I want to follow my blog over mastodon but it keep saying “follow reuqest” and can’t see any posted blogs

I’ve enabled federation in my config and i saw an old post about / in end of url so i changed that too and changed my host from http:// to https:// and still no luck

both of mastodon and writefreely hosted on same VPS. and i use writefreely binary on debian (not docker)

Is there anyone going to help or what

to update, I tried to follow my blog over friendica and it worked but not on mastodon and yes I have tried to follow my blog over other mastodon instance (not only mine) and got same results so problem with mastodon and writefreely for some reason

And I tried to use --debug flag but when I follow over mastodon i do not get any reply from writefreely (no output)

If you’re seeing no output on WriteFreely with --debug enabled in this case, that means Mastodon isn’t sending your instance any requests.

If your instance was misconfigured before, Mastodon will remember the old (bad) information, and future requests will continue to fail. So you’ll want to go to your Mastodon instance admin panel, look up your WF instance by its domain, and then reset its data.

1 Like

Oh hi, finally. I thought it’s only me who is online around here (my post) :joy:

And Oh how come I did not see this before? I think you are right. because I went to mod tools and added my blog URL then I re-synced it with mastodon (edit profile > moderation > federation - and type your blog URL) and it took some seconds but now I can follow my blog yes and it works.

And now I have a new question so I notice that there is b as my profile picture, Is there a setting to change this?