Can't find my own domain federation handle

I am a Pro user and connected my domain ( to the write as blog ( I can reach the blog using that domain.

I also activated the federation but on Mastodon I can’t find the Federation handle with my domain name, as entered in “Customize” ( Instead I can find .

I’ve sent an email requesting for assistance without receiving any response. Hope somebody here would give me some help.


Hey Mario, I was able to find your domain by searching for it by its full URL ( But for some reason, Mastodon isn’t seeing that it should use your custom domain.

I’ll need a little more time to dig into this, and get back to you here.

Thank you Matt. I’m looking forward to hear from you.

I found this. Hope it helps.

Hi @matt , do you have any news about this issue ?

I’ve tried to change the name from to with no success. Then I’ve also tried to deactivate the ActivityPub (to activate again after) deselecting the checkbox but it seems i cant’t do this.

Probably I may try create a new blog but I’ve not found a way to delete first.

Kind regards

Sorry for the delay! You should be all set now – your blog will show up when you search for it in Mastodon.

For some reason (still investigating), we didn’t properly note that this domain is secure internally, so your fediverse information returned an http URL instead of https, which it doesn’t like. That’s why you couldn’t find it.

Please note that the fediverse doesn’t work well with changed usernames here – every time you change it, it’s like creating a brand new account in the fediverse. So I’d recommend picking the name you like, then following that.

Thank you @matt . Now it’s ok.