Cannot read data; incorrect format with iOS app

Hello all.

Installed my own WriteFreely instance a few hours ago and started blogging. Learned about the iOS app and downloaded it. At first, I was able to see all my posts. But as I continued to add posts, they disappeared one by one, showing a message:

Error The data couldn’t be read because it isn’t in the correct format “

I am running WriteFreely on my home server behind Nginx Proxy Manager, using the SQLite3 option.

Some troubleshooting showed npm was not “forcing” SSL so I fixed that but that hasn’t helped.

Anybody have any other ideas?

Instance is here

Hey @fyrfli, thanks for reaching out and sorry for the bother!

To clarify: this error you see, and the posts disappearing — is it on the iOS app, or on your WriteFreely instance?

Hey there. Sorry for the late response. I apparently am not getting notifications through email (will have to see about setting that up).

The posts are disappearing in the iOS app but they exist on the server.

Since this post, I tried re-installing from scratch and managed to “fix” the error, but lost the ability to “follow” myself from my Misskey instance. And then got caught up with other things. I’ll see if I can recreate the problem and update here.

Updating this because whatever the problem was, reinstalling fixed it. But now I have a new problem … the database says I am following, but the posts don’t show up on my Misskey instance feed and if I search for my WF instance and attempt to follow/unfollow, it just sits there stuck on “Processing…”. Same thing from my mastodon.coffee account. Just gets stuck.

Did I mess up something by reinstalling without unfollowing first?

@fyrfli Do you mean that reinstalling the iOS app fixed the issue, or that reinstalling your WriteFreely instance fixed the issue?

Sounds like there are still some things with your WF instance that need a bit of troubleshooting, but I’m afraid I’m a little less familiar with that — maybe @matt has an idea on what’s happening there.

Reinstalling the WF instance.

I had tried uninstalling and reinstalling the iOS app before and that didn’t seem to help. So decided to scrap the whole instance (it’s brand new so there was nothing really to lose). But with the WF clean install, the iOS app is working (I can read posts and create new ones) and other people can find and follow me on the fediverse.

The one remaining “issue” is not being to “follow myself”. When I check the database (MySQL), I see that there is one follower registered and I am wondering whether that’s the disconnect. WF sees me as following but the fediverse got its wires crossed somewhere.

1 Like