Cannot Login to writefreely instance

I have successfully run my writefreely instance and the empty blog page shows up. I hovered on the menu button and clicked the log in button which took me to a log in page, but I’m not sure what my login credentials are and there is no sign-up button either. The only credentials I remember setting up while setting up writefreely is my database username and password which I tried but it says “incorrect password”.

I checked the documentation, but I didn’t find anything on logging in. I also tried signing up here, but the credentials for does not work on writefreely; it says “user does not exist”. How do I find or create my login credentials?

Writefreely by default is not connected to unless you configure the Oauth. I think you must have chosen “Registration closed” during configuration setup.

You can temporarily enable the registration so you can register yourself. This can be done by modifying the open_registration variable under [app] section in the config.ini file. Once you register yourself, you can choose to disable it again.

1 Like

Thanks for the reply!

I have enabled registration, but I still don’t find an option to register. I tried looking at the docs, but that wasn’t helpful.

@Dami If you are comfortable with the command-line interface, check the User Administration section in the documentation.


I second @arg — to log in you’ll need to create an admin account through the command-line interface, just like how you used it to start your instance. The command is as follows:

writefreely --create-admin username:password

Once you do that, you should be able to log in to your instance with those credentials. Hope that helps @Dami!

1 Like

Thanks! I am able to login now.