Cannot Change Host (Mastodon domain) in App Configuration

troubleshooting

#1

right now there is no way to change your host (Mastodon domain) in App Configuration.

I run WriteFreely on my Yunohost server.

When I first started, I had a blog.arkadi.nohost.me domain, but recently changed to my own domain.tld -> blog.arkadi.one

It seems federation is first setup automatically but there is no way to change it later. this should be changed I think because federation with activity pub is one of the killer features of WriteFreely in my opinion.

*** Seems like the only way to change this is for me to uninstall WriteFreely and then reinstall it again. This is another major problem because I can export posts as a ZIP file but cannot re-import them.

Is there a way to change it manually in a *.conf file or something?

Thank you!


#2

I think you have a domain configuration problem. If I go to https://blog.arkadi.one it’s work like a charm… but all post links point to the wrong domain name.

Sample:
https://blog.arkadi.nohost.me//new-url-for-arkadi-cloud

Maybe your Fediverse problem is related.


#3

In a default installation, the configuration for the domain is stored in a config.ini file. The property you’d need to change here is the host in the [app] section. (Here’s the documentation on the config file.) I’m not sure what’s involved to do that on YunoHost, but if you can access your files, you should be able to edit this file.

Note that when you do this, federation to existing followers won’t work anymore – they’ll need to re-follow you on your new host name (this is an ActivityPub thing, not a WriteFreely one).


#4

Hello.

  • Not sure it’s a domain problem, but possibly a Nginx problem. I had an Nginx problem when i switched domains before and had to restore WriteFreely from a backup. All my other apps on Yunohost (Debian) work fine with new domain: nextcloud, Transmission, Roundcube, Pi-hole etc.

  • I tried changing that config.ini, then restarting writefreely.
    They didn’t have a host name in the config file but

host = DOMAIN_URL

maybe I need to modify something in: /etc/yunohost/apps/writefreely/settings.yml It already has the right domain there.

domain: blog.arkadi.one

At this point it looks like I need to reinstall WriteFreely as it isn’t integrated into Yunohost very well.

*** Is there a way to import all my posts back into WriteFreely? with the json file?

I’m posted this as an issue at https://github.com/YunoHost-Apps/writefreely_ynh/

I will see what they suggest.


#5

i just posted a post to test something on my writefreely blog. it automatically makes the link post to the old domain like this:

https://blog.arkadi.nohost.me//want-by-cindy-pon

but if i change the URL to https://blog.arkadi.one/want-by-cindy-pon it works.

very strange.


#6

[SOLVED]

got some help from GitHub

/var/www/writefreely/config.ini is important to change

changing

/etc/yunohost/apps/writefreely/settings.yml and conf/config.ini doesn’t do anything.

hope that helps another yunohost person