Auto Format of Dashes -- becomes a long - and breaks code

Various codes, the intro divider and subscription, for example, require double dashes. On my iPad and iPhone and Computer, I have auto formate turned off so this does not happen. However, for some reason it is happening now.

Here is my test page, where it publishes as an elongated dash rather than a double dash, but when I edit it it is a double dash (until I publish it), breaking the code. What am I missing please?

With abandon,
Patrick

So the “Read More” markup is actually <!--more--> instead of <--!more-->, so that should help there.

As far as the email subscription markup goes, <!--emailsub--> is correct. Make sure that you go to the Customize settings of your blog, scroll down to Updates, make sure that “Email Subscriptions” is clicked on, and save changes. That should activate the markup to create the email subscription box.

Hope that helps! Let me know if those do the trick.

Solved! Thank you, @cjeller1592!

1 Like