Testers for WriteFreely 0.12 Release Candidate

For the upcoming WriteFreely version 0.12 release we are going to put out a release candidate for testing. We’re looking for instance admins who’d want to try it out and give feedback. Let us know if you’re interested!

Count me in :nerd_face:

1 Like

The WriteFreely 0.12 release candidate is now live! Check it out below and let us know what you think:

For me it fails to build on CebtOS 7:

[fedidev@server writefreely]$ make build
go-bindata -pkg writefreely -ignore=\\.gitignore -tags="!wflib" schema.sql sqlite.sql
go get -tags='sqlite' -d -v ./...
go: github.com/writeas/impart@v1.1.1-0.20191230230525-d3c45ced010d: invalid pseudo-version: git fetch --unshallow -f https://github.com/writeas/impart in /home/fedidev/go/src/pkg/mod/cache/vcs/958d5d59e50002212553135624d776253b468040795102a79acec486f36c6922: exit status 128:
	fatal: git fetch-pack: expected shallow list
make: *** [deps] Error 1

I think you haven’t pushed github.com/writeas/impart v1.1.1-0.20191230230525-d3c45ced010d version to github.com/writeas/impart - latest tag there is still v1.1.0.

Hmm, I’m not quite sure… But I did find this StackOverflow answer about an old version of git that ships with CentOS 7. Maybe that’s the issue?

Yep, on CentOS 7 I have git version

But on WriteFreely’s go.mod I can see dependency set on github.com/writeas/impart v1.1.1-0.20191230230525-d3c45ced010d - is that ok?

Because github.com/writeas/impart latest version on GitHub is v1.1.0.

Yeah, I’m not quite sure how to parse that version number. I think it’s supposed to point to the latest commit on master. But to be sure, I’ll push a tag and update go.mod in WriteFreely.

Okay, I’ve updated the develop branch – give that a shot and let me know if that works.

Thanks - it builds now (still on git v.1.*) :nerd_face: Just built from develop branch and installed on fedi.dev :relaxed:

Built on:

CentOS 7
go version go1.13.6 linux/amd64
git version

Awesome!! :tada: Glad that fixed it.

1 Like

I will start exploring :nerd_face: Already like updated admin dashboard very much :+1: Curious to try out ActivityPub mentions and I’ll try to setup OAuth with Gitea as described in your tutorial.

1 Like

Is it just for me or ActivityPub mention doesn’t work on this post? :neutral_face:

Hm, clicking the mention seems to work fine… What didn’t work, the notification? Or something else?

It seems in post itself fediverse handle (@gytis@mastodon.lt) is parsed, but when I try to reply from Mastodon, only blog handle (@gytis@fedi.dev) is mentioned :thinking:

I have added few more fediverse handles in the post to check mentions.

Update: mentions work as expected - problem was because Mastodon cached post which initially was without additional handles to mention. I have created one more post and this time it was fine with both Mastodon and WordPress fediverse handles :+1:

Ah, yep. Unfortunately Mastodon doesn’t handle the Update activity we send out, so it doesn’t update the post. Glad the new post worked!

So it wasn’t an issue using git v.1 on server that had sources initialized from earlier, but on blank CentOS server I’ve set up freshly it is required to have git v.2 - otherwise go get doesn’t pull anything.

There is quick guide on how to get git v.2 on CentOS 7.

I will update my build WriteFreely from source guide :nerd_face:

1 Like

I’ve also came across some more SELinux denials (this time with static files), but this guide helped to address them.