Amazontrust now?

@matt I class this as a bug. Highly frustrating to me.

Why does the customize page now require a connection to amazontrust? This is not on in terms of privacy, GDPR, and others.

I don’t want, nor shall, accept connections to amazontrust.

Because of that, it has become impossible to save the customize page. When clicking save:

|error_msg|“Expected valid form data.”|

Hmmm where are you seeing a connection to amazontrust? I believe that’s what generates SSL certificates for our CDN, but I’m not sure why you’d personally see any connections there from your browser.

Can you share a screenshot showing the connection?

Here you go.

Is this from a browser extension or something? If so, which one?

little snitch by obdev

Thanks. Does it tell you where exactly that request is being made from? Otherwise, is this happening on other random sites, as might occur if another installed browser extension is making these requests for you?

Again, we haven’t added any code that makes these requests. And while inspecting with my browser’s developer tools, I’m not seeing the same requests being made.

I use a separate browser I use for exclusively.
It is a stripped-down privacy enhanced firefox.
It does not have any plugins.

I just did a test of quitting the browser and logging back in.
Last connection to amazon is an hour ago, it looks like it has not been quiried again.
I do see, which is a new one to me. I’ll next try to see what that does.

one step at a time. Blocked, and now I get


replied here: is only there to work around domain-level internet censorship, like what we see in China right now. But yeah, disabling certain parts of the application can definitely break it, and we can’t reasonably support every possible configuration like this.

This is exactly why we self-host all aspects of the application, as mentioned in our privacy policy, so readers and writers don’t have to do this kind of stuff. If you don’t want your visits to count in our first-party analytics, you can enable Do Not Track (DNT) in your browser – we’ll respect it.

1 Like

Sorry @matt, still ongoing.

amazontrust seems to be needed on the blog customization page.
get quieried on this specific page:
https:// /me/c/ BLOGCUSTOMIZE

I think that’s where the customcss and customjavascript get issues.

Can you share a screenshot of your dev tools console please? Open it up, then ctrl+shift+r to reload the page.

There you got me matt, what’s the dev tools console?

Sorry, you can access by right-clicking on the page and clicking “Inspect,” or press Ctrl+Shift+C, then select the Console tab. Then just send a screenshot of what you see there – it will show any errors on the page.

Thanks Matt. Hope I have what you needed? See PM.

Just responded there – it looks like the CDN is blocked too.

Again would stress that issues will continue popping up if you’re only putting URLs on an allowlist for our site or blocking resources :slightly_smiling_face: They’ll continue to shift around over time as we improve and optimize different things, so it’s extremely likely this will happen again in the future.

As a heads up, note that I’m fine helping fix things this time. But going forward, I can’t provide any more support on these custom configurations, as I think you can see this takes up a disproportionate amount of my time.

I think we worked out that most of these issues were caused by local configurations, and I highly suspect that the amazontrust one is, too. I’ll leave that up to you and the community to figure out and share with us – but I’ll need to bow out of this conversation to work on other issues.

Please let me know if you run into anything else unrelated to these issues.

Thanks for standing by trying to solve Matt. CDN is not blocked. Only amazontrust.
Totally understand there are other issues to tackle.
Maybe it’s an idea to simplify the setup? 7 domains for one service with different CDN’s, but I’m a simple man with no clue to manage servers :blush: